Unable to Update Roon Bridge on Intel NUC with Linux (ref#J7VQAV)

Affected Product


Roon Issue Category

Description of Issue

I currently have a Roon Bridge in the form of an Intel NUC, programmed with Linux. Roon keeps attempting to update the Bridge but it always fails—i’m assuming because Roon isn’t geared toward updating Linux software. However, everything works just fine so i’m wondering if i even need to update the Bridge? Current build is version 1.7/build 571

Unfortunately the Hi-Fi shop that originally programmed it for me (and also originally talked me into subscribing to Roon) has gone out of business and updating Linux is beyond my technical ability so if i have to update the bridge i’m not sure how i’ll go about it.

Roon Core Platform


Roon Core Specifications

2010 Dell PC 16GB Ram-the core updates successfully-i am about to change Core to Mac Mini

Connected Audio Devices

N/A–this is just a Bridge updating question

Home Network Details

Ethernet–Xfinity Gigabit

This is on you to decide.

You posted here about how to update. Also there is usually no support for outdated Roon software, just current builds. Roon software usually updates itself. If you use one of your Roon clients and look at Settings|About, what is displayed there for you regarding current versions used and updates?

Note: You can post screenshots here.

If Roon can’t self-update you may have to perform a manual installation of the current software, following the installation instructions provided for new installations.

PS: Current build of Roon Bridge is 1.8 b1125.

i assumed my bridge software was out of date because it has never updated since it was installed in approx 2018. It tries to look for an update but consistently reports an error in checking for an update. Its version is 1.7 (build 571) stable. The Linux software in the NUC being used as a bridge was installed by the dealer that helped me set up Roon and he’s out of business.

the rest of my Roon architecture is up to date—Version 2.0 on my core/build 1311, as are all remotes. As mentioned in my post, everything seems to work OK but it bothers me that there might either be a vulnerability or that my bridge will eventually cease to work.

thank you for providing a link to installing Roon on Linux and providing the note about the current version and build. I had looked around the website and did not find those

Hi @Mark_Smith,

Thank you for the report. We’re investigating with development at the moment, but a more precise look at RoonBridge-specific logging will help expedite our search for the precise failpoint here.

On your RoonBridge device, please locate the RoonBridge database and use this log uploader to provide a zipped set of RoonBridge system logs.

We’ll provide updates after we’ve had an additional review - thank you for again for your patience.

Hi Connor- thanks for your response-- I need some guidance here–I’m assuming i cannot locate that file from a Roon remote or from the PC that is my Roon core and have to somehow attach my laptop to the headless NUC to see the files? If i can get that done, what is the file name for the Roon database i am looking for ?

Connor–the log uploader is not working–i’ve tried dragging and dropping the logs as well as choosing those files and it just doesn’t upload them

OK–tried something else and got the logs uploaded–let me know what you find on the bridge updating–thanks

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.