Unable to upgrade Fire 10 Tablet

Roon Core Machine

i7 NUC running Rock

Networking Gear & Setup Details

D-Link switches hard wired to endpoints

Connected Audio Devices

N/A for this problem. Problem with Remote

Number of Tracks in Library


Description of Issue

All my device upgraded successfully except my Amazon Fire 10 tablet. My other Android based phones upgraded and connect back to Core. I have the Fire 10 as a dedicated remote because I am on various VPNs all day. The Fire 10 stays on my network allowing me to manage Roon. When I go to the Google Play Store it says installed and gives me no option to upgrade. I’ve tried deleting from my tablet and reinstalling. Still when I try to connect to core it tells me I need to upgrade.

I don’t see a path forward to upgrade the tablet. Please help.

Amazon store are notorious for being the last in line to issue updated apps that have been supplied to them.
Maybe have to just wait a little while longer

1 Like

@dylan, you are the only one I know in support. Can I get some official word about what the problem might be? Its still an issue. While I appreciate @AceRimmer response. I’d like to know if there is something on my end, Roon’s or are we at the mercy of Amazon.

If Amazon why is is different than Google Store…which is where the Roon notification in 2nd screen shot takes me? I understand there may have been, or still is, an Amazon specific app store at one time. But that is not the case for me. I have one job for this tablet. To function as a Roon remote. Nothing else is installed on it. Google Play store will not provide an update that lets me use Roon. Core tells this Remote it has to be upgraded. I’m stuck in no mans land. Please help.

Maybe instead of waiting you want to try the following?


Hey @RPlace, sorry for the delay in getting back to you about this! It’s awesome to see that you received a few helpful replies already - were you able to give the latest suggestion a try?

Let us know if you’re still not able to update and we can continue the conversation. Thanks!

Did not try the suggestions above, @ashley . After a few more days it updated itself. I’m unclear as to why, but once working again I just accepted it.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.