Unexpected error loading album. Please try again later

Hi
When I try to log on to Roon. I get this error “Unexpected error loading album. Please try again later(NotAvailable)”. At the bottom of the page “No audio Devices Found”.
My gear is iMac 27", 3.4 GHz, 8 gb. ram, 1 tb hard drive, MacOs 10.13.5. ,Roon 1.5 on trial periode.
My iTunes library is 174.56 gb., 13 984 songs.
When I play music on Tidal Hi-Fi or on iTunes it works fine. I use an Hegel Super USB dac for headphone use, or a Squeezebox Touch connected to the dac of an Hegel H300 amp. I run the Logitech Media server version 7.9.1.
My system work flawless, so its frustrating that I can’t get Roon to work. Up to my knowledge I have tried everything to get Roon to work. When I first log on too Roon I didn’t download my music, I only logged in my Tidal account. It worked super. The soundimprovment was awesome! The error started when I tried to connect to my iTunes library. My mac froze several times.
I hope you guys can help me.

Your sincerely
Morten Zenker

Thanks for reaching out, @Morten_Zenker!

May I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you also confirm if there is any active firewall or antivirus on the Core machine?

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thank you,
Dylan

Hi Dylan
I have an Apple Time Capsule 3 tb, wired to my Network providers modem (500/500 mbps). My iMac and Logitech Squeezebox Touch is running a wireless connection. I have no firewall or antivirus software activated.

Thank you,
Morten

Thanks for the setup details, @Morten_Zenker — I appreciate it!

Moving forward, I’d like to propose a test that should give us additional insight into what you may be experiencing. Please see the steps below:

  • Locate your Roon database according to these instructions
  • Rename the entire Roon (or RoonServer) folder to roon_old
  • Relaunch Roon, sign in, and configure a new install

Once you’ve done the above let us know if you are experiencing the same behavior.

Thank you,
Dylan

Hi Dylan
I was now able too load the Music folder. Roon froze after 12 889 song and 3131 albums. A couple of minutes afterwards froze my iMac. I have tried run Roon 3 times with the same result.

Thank you,
Morten

Thanks for giving that a try, @Morten_Zenker!

I’ve enabled diagnostics on your account once more. Once the report is uploaded I’ll pass it over to the team for analysis and will update you as soon as I receive their feedback.

Kind regards,
Dylan

Hey @Morten_Zenker,

I spoke with the team, and they’d like to propose a test to help narrow down what may be happening. It may be an issue with the drive on the machine you are using. Do you have another machine you can test with as your Core and see if the same behavior occurs there?

Thanks,
Dylan

Hello Dylan
We have installed my Roon account on my sons Windows machine, and it worked fine. He hasn’t a music library, but Tidal and audio devices worked flawless.
If it is an issue with my drive, what do you recommend? Clean install? Is there some issues with my iTunes library? I first installed it in 2009 an sinces copyed trough 4 different Mac´s? What do I do when try I to install it from my backup? I guess the problem would be the same. Replace hard drive or my iMac?

Thank you!
Morten

Thanks for testing that out for us, @Morten_Zenker!

Can you confirm how much space is available on the Mac’s drive? Also can you confirm whether or not it is an SSD?

If you make a copy of a small portion of your library and only add that small portion as a watched folder do you experience the same behavior? Or is it only if you add the entire iTunes library?

Thanks,
Dylan

Hello Dylan
It works!!! I made a map called iTunes Music 1 with 1896 songs. And i can play Tidal songs and from my library.
So, a little question: How can i play Roon trough my Squeezebox Touch? I have turned on “Enable Squeezebox Support”. But I don’t get it up as an alternativ on Audio output?

Big thanks,
Morten

Hey @Morten_Zenker,

That’s great to hear! I would look into your storage space and see if maybe there isn’t enough room for the database once the entire library is imported.

If you connect the iMac and Squeezebox via Ethernet are you able to see the Squeezebox Touch in Settings > Audio?

-Dylan

Dylan, Dylan, Dylan!
I connected my Squeezebox to my iMac with an ethernetcabel.
It is working! I can play music trough my Squeezebox. I am so fu++++ happy.
Thank you for all of your support!
This is going to be a fantastic weekend?

Thank you very much!
Morten

1 Like

Hello again
A little problem came up. I restarted my iMac this morning, and my Squeezebox disappeared from Audio settings. I have tried to restore to factory settings on the Squeezebox, but nothing works.
Any suggestion?

Thanks
Morten

Hey @Morten_Zenker,

Sorry to hear that it’s no longer showing up here! If you reboot the devices and networking hardware do they show up? Is it still connected via Ethernet?

-Dylan

Hey Dylan
I have restarted router, Squeezebox and iMac.
It is still connected via Ethernet. Squeezebox i running 7.7.3.
LMS is turned off.

Thanks
Morten

Sorry to hear you’re still experiencing that, @Morten_Zenker!

By any chance do you have a different router available that you can test with? As noted in our networking guide, we’ve seen some performance issues with Apple’s networking hardware. Know if the same behavior occurs with a different router would certainly help narrow down where the issue may be stemming from.

Thanks,
Dylan