Unexpected error when adding network folder, synology core


(bin xiao) #1

Synology 1817+ and Synology 918+ both core servers are running OK. They both can’t add a network path. The message always show unexpected error. \IP\folder name OR smb://IP/folder name. Same address was tested under MAC and Windows. Both OK. I even tried \IP or smb://IP both showed ‘invalid network path’, which is tested OK in MAC OS X and WINDOWS.

1817+ or 918+ locates at the same VLAN of network folder source. network should be no problem at all.


(Noris) #3

Hello @bin_xiao,

Can you please post a screenshot of the SMB settings and the error that Roon is displaying? You should be able to add the network path’s using these instructions. What kind of network share are you trying to add? Are you trying to link the NAS to each other or to a library located on another computer?

Thanks,
Noris


(bin xiao) #4

I’ve tried the mac version and windows version core. they both can add the a network share from my another computer or NAS. But even the mac and windows version, the network share don’t accept the \\192.168.1.100\ or \\192.168.1.100, you have to add the Directory,that means you can’t use the root Directory to share. Mac and Windows Core only work when you use \\192.168.1.100\music
The only difference is the RED error message “Unexpected Error” shown

on the screenshot of network folder add when using the Synology Core.


(Noris) #7

Hello @bin_xiao,

We’re going to do some testing on our end to see if we can reproduce similar issues with pointing one Synology to another, but are you absolutely certain that the IP address is valid on both of your Synology drives? Can you please check in the Router or use FING to verify this fact?

Thanks,
Noris


(bin xiao) #8

2 locations. I am a network pro. 15 years in IP Network for Telecom Carrier.
First location: layer 3 switching , router 192.168.10.1 - 192.168.10.2 Layer3 switch 192.168.20.1/24 - Wired ROON on synology 918+ , audio devices , ROON controller computer and SSID for mobile devices.
Second location: Router on stick, VLANs on Router sub-interface. router 192.168.1.1 – same native VLAN – ROON on synology 1817+, audio devices, ROON controller computer and SSID for mobile devices.
All synology NAS updated to newest firmware.


(Noris) #10

Hello @bin_xiao,

Thanks for letting me know that info. We took a look on our end and have not been able to reproduce this issue so I am thinking that this could be networking related. I have two follow up suggestions:

  • Can you please manually send us the logs from your machine that you are using to connect to that share? You can follow these instructions to get it over to us (if you don’t have Google Drive or Dropbox just let me know and I will provide an alternate upload method).

  • Are you able to connect to that share from outside of Roon but still on the same machine? As in are you able to SSH into the NAS and are able to mount the same folder?

Please let me know this info when possible.

Thanks,
Noris


(bin xiao) #11

Hello Noris,
The following link is logs: https://drive.google.com/file/d/1_U9aNJ62QIrqvuRjMcAZjXIEFluYSU_T/view?usp=sharing

I can share from outside of ROON both on the NAS and other computers or mobile phones. I even mount the share folder on synology correctly from the 2 computers, you can see from log. I can read, write on the NAS mount folders.
share1: \192.168.20.100\temp
share2: \192.168.20.187\Movie

Hope these can help you to find the solution.


(Noris) #12

Hello @bin_xiao,

Thank you for sending us those logs. I have started a case for you with our QA team and have asked them to take a look. I will be sure to let you know what they say once this request reaches their queue and appreciate your patience until then. Thanks!

– Noris