Unexpected Error when adding network shares

Core Machine (Operating system/System info/Roon build number)

ROCK/ NUC8i5BEH/ Rock firmware 1.0 (Build 227)/Roon Firmware 1.8 (build 756)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NAS WD MYCLOUDPR2100-Ethernet-Apple Time Capsule

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mac Mini roon remote, Denon 3500x airplay, apple tv, chromecast

Description Of Issue

Setup ROCK on a new NUC yesterday. I previously had my CORE on my daily mac mini. I have been trying to add the same network shares to the ROCK so I could restore my backup but all I get is “there was an unexpected error: Unexpected error”

I checked again and actually went through the steps to setup again mac mini and the network shares had no problem being added to that.

Hello @Jack_Herbert and welcome to the forum.

Do you use the host name or the IP-Address to connect to the NAS? If you use the host name, please try to use the IP-Address instead and see if it works that way.

What is the “Max SMB Protocol” set to? If it’s set to 3 or higher, can you try to set it to a value lower than 3 and check if it works then? Note: Not needed if the change to IP-Address from above already worked.

1 Like

Blackjack I changed it to smb1, smb2, smb3 and it worked!!!


Great to hear that it worked for you. If there is a possibility to set it to SMB 2 and 3 (omit SMB 1) you should do that. SMB 1 is vulnerable and obsolete nowadays - try to avoid having it active.

1 Like

Thanks man! I changed it to SMB2 and SMB3 still finding the music fine on the NAS. You really helped me on this one.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.