Unexpected Error when network share to Roon Nucleus

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus (Rev. B) running OS V1.0 (build 186). Roon server software V1.7 (build 537). 1T SSD installed, formatted and confirmed ‘OK” via the Web Administration Interface.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet connection

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Lumin T2 also connected to the same network via Ethernet and Mac Mini Pro (2018) connected via WiFi.

Description Of Issue

When trying to Add a network share to the Nucleus following the instructions from the knowledge base—using smb://NUCLEUS/Data/Storage/InternalStorage as the Network Share location and entering Guest as name and password (also tried without this)— I get the “There was an unexpected error: unexpected error” message. I tried reboot and reinstalled the Roon OS with no luck.

I would like to be able to have the music files from my Mac Mini be backed up on the Roon Nucleus. I currently have the Mac Mini shared to the Nucleus, but I don’t want to have to keep the Mac Mini on to stream my music files.

Appreciate any insight to what I am doing wrong.

Thank you!

Hi Anthony,

Just to confirm, you’re trying to copy the music from your Mini to the internal storage of the Nucleus?

If so, what you need to do is open a Finder window on the Mini. Then, at the top of the screen click Go, then Connect to Server.

Type in smb://Nucleus/Data/Storage/InternalStorage and then login in via Guest.

Open another Finder window and navigate to your music. Then drag and drop.

Hope that helps.

Cheers, Greg

Hi Greg.

Still no luck. I tried the steps above and get a message that states: There was a problem connecting to the server “Nucleus”. The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

I tried both suggestions. I am connected to the same network (Nucleus through Ethernet and Mac Mini via WiFi). I restarted the Nucleus several times and tried with no music streaming.

Also, I never get the option to enter in Guest as username and password.


Hmmm. Do you have a Nucleus Plus? If so, you need to type NucleusPlus instead of Nucleus.

You could also try using the IP address of the Nucleus instead of the word Nucleus.

Thanks Greg. IP address was the fix. All is good now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.