Unexpected failure communicating with audio device

Roon Core Machine

Roonserver Docker container running in unRAID 6.9.2
Xeon E3-1245v5, 32GB RAM, Docker containers in Samsung Evo 860 250GB SSD

Networking Gear & Setup Details

Ubiquiti UDM Pro, USW-16 / USW-24-G2 switches

Connected Audio Devices

Matrix Mini-i Pro 3 (Ethernet to USW-24-G2)
Lumin X1 (Ethernet to USW-24-G2)

Number of Tracks in Library

25k tracks

Description of Issue

  • RAAT playback on Matrix Mini-i Pro 3 consistently fails with the following error:
    “Unexpected failure communicating with audio device”
    “Too many failures. Stopping playback”

  • Playback on Lumin X1 is flawless and stable, both connected via Ethernet to the same switch.

  • Roon via Airplay to Matrix Mini-i Pro 3 also works flawlessly.

Prior to today, RAAT on the Matrix Mini-i Pro 3 was spotty but worked. Playback would simply stop after a random amount of time (30-90 minutes). Have performed a cold restart of both the Matrix Mini and the Core (including the unRAID host).

Ok so after numerous restarts of Core and endpoint to no avail, what finally got it to work was disabling Parametric EQ and Procedural EQ (which I had been using for mono output). Oddly, toggling it back on still works, but for now I have it off to test and RAAT has been streaming for over an hour without issue…

Hi @jtsc,

I wanted to check in and see if you’ve experienced any further issues with playback on the Matrix Mini-i Pro 3?

We’d love to help in any way we can.

Thanks! :pray:t3:

So far it has worked flawlessly since (with DSP disabled). I’ll get around to re-enabling it soon and will report back if problems return. Thanks!

So, re-enabled DSP and the issue started again. Turning it back off promptly resolved it. My settings as follows:

With DSP enabled, after starting playback to the Matrix but before it stops with an error, could you capture a screenshot of the signal path?

Do you experience similar errors regardless of the sample rate of the music? 44.1kHz, 192kHz, DSD?

Also try setting the Max PCM rate to 192kHz for the Matrix, see if this helps. If 192kHz + DSP works, then try 384kHz.

Thanks for chiming in Peter. Yes, it’s likely the source sample rate has something to do with it. When it consistently failed previously I was attempting to play an album - all with the same sample rate. When cycling through Roon Radio, it works for a while then eventually stops.

Here’s what the signal path looks like this when it works:

After cycling through some tracks, it eventually failed on tracks with this sample rate:
FLAC 48kHz 24bit, MQA 96kHz

And going back to a 16bit 44.1kHz track subsequently works fine again.

So it looks like nothing to do with the Matrix Mini - I tried the same DSP on the Lumin X1 with the same error. Drilling down further, it’s only the Procedural EQ (to create a mono mix) that’s causing this. I followed the instructions from this post:

And furthermore the error only seems to occur with higher bit rate material (16/44 is fine).

Why is there a “7.1” channel mapping? Can you set the EQ in a way that the 7.1 does not appear?

And why do you want to create a mono mix?

Peter, not sure why it appears as a “7.1 channel mapping” but I’m simply creating a matrix routing in the procedural EQ to route Left->Left, Left->Right, Right->Right and Right->Left, each reduced by 3dB, to create a mono output (wish there was a simpler way to do this).