Unraid Roon Core - ‘waiting for core’


I installed Roon yesterday on my unraid server using Docker. All seemed generally fine while I was evaluating it. I imported my music and connected 4 devices, an iMac, iPad, iPhone 6 and an Aries Mini. All worked more or less flawlessly.

This morning I grabbed my iPad to continue my evaluation but I kept getting the message, ‘waiting for core’. I reset the app a couple of times but that didn’t work. I tried my iPhone but received the same message.

The server is up and running as is the Docker. All are on the same network.

The only thing that has changed since yesterday is a reboot of the server last night.

Following the advice from @support in another topic I found, I selected choose a different core from the iPad and reselected my unraid server which was listed. After being prompted to sign in again, it seems to have reset the whole thing, taking me through the entire setup process again, showing no music, no storage shares or connections to music services.

Please tell me I don’t have to go through the whole thing again and my previous core has been overwritten!

And I assume this is not normal behaviour, every time a core server gets rebooted?

Any help or advice most welcome.

Hello @BenniMac,

Can you point us to what Docker image you used to install Roon Server? I will be difficult to figure out what is occurring here without any knowledge of the image or installation method.


Thanks John.

The docker details I used are as follows:

Name: Roon
Repository: ronch/roon-server
Network type: Host
Privileged: Yes
Bind time: Yes

From this thread:

Sorry @john, I forgot to tag you in the above.

@support is this forum the only way to get support for a $500 app? I ask because as you can see, my experience so far has not been great.

I’m sure this is probably me doing something stupid but I could really do with some assistance.


Hello @BenniMac,

We apologize for the delay, I brought this issue to the development team for further investigation and have been waiting for feedback. I just checked the status of the ticket, they are looking into the docker container to see what could have caused the behavior you are seeing. The ticket is still open, I hope to have some further feedback for you in the next few days.

In the meantime, could you tell us what the current state of your Roon setup is? Is it asking you to re-login after each reboot of the system? Or did this only occur once and now things have settled again?


Thanks @john for the update. No, it is doing it every time I reboot. It works perfectly fine while the server is running, but as soon as I reboot, it seems to clear all the Roon folders. I even tried rebooting before I imported any music (in case my music share was the problem) but it still does the same thing.

The second time I went through the import process, I immediately created a backup on another server. This completed successfully. When I try and restore from this back up, the process completes successfully, flashes up briefly my Unraid server as a valid core, saying ‘last seen 20 mins ago’ (about the time of the restore), then that disappears and it just says ‘looking for core’.

I assumed I had missed something in my Docker configuration, but @Christophe_Beuille kindly sent me a screenshot of his configuration and it is the same as mine (to my inexperienced eyes at least).

I’m running the latest version of Unraid 5.6.3

All very strange. It’s a great app and I’m really liking it, I just need to get it stable on my server.

not that it’d change anything, but you surely mean 6.6.7, don’t you ? :wink:

I’m about at as much of a loss as you are here, but one thing worth checking is where the database is exactly. You might want to try /mnt/cache/appdata/roon/application/ rather than /mnt/user/appdata/roon/application/ .

As an aside, and this certainly not related to the issue you’re seeing, I’ve found that forcing my music share to a single disk made things a bit better (because there’s no spinning up and down of drives).

@BenniMac maybe post your unRAID docker config? If you’re still using it?

I’m wanting to shut down the additional machine I’m running ESXi (for only Roon now) and move it into my unRAID box. I had it running a long time ago in a docker. but I cannot recall if the issues I had were unRAID stability problems or docker issues.

If you’re losing your config on reboot it’s likely a data folder mapping issue.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.