Unusable performance

Great - just wanted to make absolutely certain the basics were solid. Roon’s topology (and language) can be a bit daunting to new users, and the documentation is a bit confusing at times.

Another dumb question then: have you tried browsing from the all-in-one ?

[edit: it really is a dumb question. got confused between the different windows machines. sorry]

@Xekomi, do you think it’s worth @Kenny_Watt trying Roon Server on the Sony and controlling from his laptop? It would eliminate the Sony graphics system from the equation to aid diagnostics even if it’s not a final configuration…

1 Like

Absolutely, yes.

Hi @Kenny_Watt
Exactly what model is your Sony? Some that I see with your CPU don’t have an SSD, another one or two have pretty small (32GB) SSDs that I would imagine are nearly full of the OS.
If the Roon Database isn’t on your SSD things will be sluggish on a spinning drive.
One of the Roon folks might be able to tell you whether Roon has been installed on the SSD or not. I don’t know enough to help there.

If the music is on a NAS and your core is on WiFi connection that will not be helping either.

FYI https://kb.roonlabs.com/FAQ:_What_are_the_minimum_requirements%3F

And also see Suggested hardware

And on the networking side see https://kb.roonlabs.com/Networking_Best_Practices

This sounds more like a Windows problem rather than a Roon problem. Check for unwanted / unneeded processes running in the background. They could use up cycles in your Sony’s CPU. Needless to say, make sure that Windows is fully updated.

Hi @Kenny_Watt,

Sorry to hear your struggling with this … I’ve moved this topic over to the support section of the forum and restructured your first post to reflect the format that @support prefere so they can follow this up for you.

I connected from this PC to those servers via a 5G WiFi network.

This would certainly be of concern, but I read you also tried connection via wired ethernet …
Was that with all devices connect via wired (so no WiFi involved between Roon, the NASs and the internet)?

PS I’ve also changed the status on your account to enable you to post images and this may help going forwards.

Hi. All devices involved are connected via wired Ethernet (computer with Roon and both servers -Synology and Naim).

Not sure if you got a message I sent earlier about what Task Manager told me. The PC is not stressed. CPU varies between 2-12%, generally around 5. Almost all of that is Roon. Memory usage isn’t high either (8G fitted). Oddly, there’s a varying but consistent chatter on the network of around 4Mbit/s. The computer has very little installed or running. Other applications run fine, including Spotify, which scrolls, navigates and plays quickly - despite calling all that from the internet, where Roon is presumably local. I really think this is a Roon problem.

Hi again,
Thanks for the update

Roon support will likely enable diagnostics on your install and then check the Roon logs for pointers.
I’m 99% certain the poor performance will be down to local environment, but specuation won’t help … so let’s see what @support can find, but note this below …

Hi @Kenny_Watt — Thanks for reaching out here!

I’ve reviewed the troubleshooting you’ve tried above (thanks everyone for the great suggestions so far) and wanted to summarize here:

  • Analysis and re-scanning is completed, so that’s not an issue
  • Remote devices are not connecting
  • You’ve tried 32 bit Roon on the remote (but not the Core)

Is the above all correct?

Can you share this via a shared Dropbox link?

The fact that your remotes can’t connect is definitely interesting — While this type of slowness doesn’t always indicate a networking issue, it would be good to know if you see the same behavior on other remotes, and the networking issues definitely wouldn’t help here.

Can you describe your networking setup? Are all devices connected via WiFi?

As we note in our requirements, we always recommend that the Core be connected via Ethernet. Is it possible for you to connect the Core in this way?

1 Like

Hi Dylan. All the above is correct.

Hi. The Sony (Core) is connected via ethernet to a router/switch that also hosts the Naim and Synology servers. The clients were connected (or rather not!) over WiFi in that same router/switch. From my mobile, your client sees the Core by name and repeatedly tried but fails to connect.

Not sure if you have any firewalls active. But if you do turn them all off

Hi @Kenny_Watt,

Are the devices on the same subnet as the Core?

What is the model of the router you’re using?

Hi Dylan. I sent a reply to your last post but don’t see it on the thread. The devices share switched ports on an Asus AS68U router/switch. They are all on the same subnet as it happens. Other devices share the same network. For example, from my Naim devices (clients and the Uniti Core server) in can see, browse, navigate and stream from the Synology NAS with no apparent delays.

Roon doesn’t, it doesn’t scroll in a usable way, the interface freezes for 10s of seconds but there’s no evidence that is analysing/sorting in the background. It’s possible there’s some underlying problem here but everything else I browse or stream works just fine - including browsing/streaming from a Naim client across WiFi.


So here’s a thing… I just opened Windows Media Player for the first time on that machine. It took about half an hour to scan all the album’s on the Synology NAS. Even while it was updating, I could scroll through and select albums. Once the library was complete it continued to update album artwork but I could still scroll, select and stream quickly.

The WMP is running on the same Sony PC as Roon but seems to have none of Roon’s problems. Not sure what else I can do to support my initial suspicion that your software is not performing. Even from a DLNA client on my phone, connecting over WiFi to the servers, I can scroll, select and stream music just fine.

Any thoughts?

After doing that with WMP, I just reopened Roon. It took a few minutes to start but appeared with no album art. When I scrolled the first page of albums, it stopped as it’s been doing. It’s now, very slowly, adding artwork to the page that’s visible. That’s taking minutes for just one page. It currently will not scroll.

Was that in some way relevant? It talks about instability not slow performance. Is there any specific advice on this that might help resolve the problems I’ve called out?

I really appreciate the responsiveness of the people on this thread but am not sure I’m any closer to resolving my problem with the product. Root cause analysis isn’t always easy but I think I’ve probably provided enough evidence to suggest that the problems I’m seeing are specific to the Roon installation on my computer. The only practical advice I’ve been offered is that the 32bit version may work better and that the instruction manual might help advise how I can install that over the 64bit version without having to reinstall the database. But that advice then became confused by advice that the client was the element that would benefit from the 32bit version. In tried that but it didn’t help. I haven’t tried it on the Roon server but will if I’m given a clear indication of why that’s likely to fix the problem I’ve reported.

Are there any other thoughts on why I’m getting this experience? Is it common for users to experience these sorts of problems?