Unusable performance

Core Machine (Operating system/System info/Roon build number)
Sony computer running Windows 10, i5-3317 U/1.70 Ghz with 8GB of RAM.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Naim Uniti Core and Synology multi-disk NAS with 5073 albums/59,805 tracks split across them.
I connected from this PC to those servers via a 5G WiFi network.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Hi. I’m a new user of Roon. I have it installed on an Intel computer running Windows 10 certainly sufficient for the requirements for Roon at the time I placed my order. Unfortunately, the performance I get from Roon makes it almost unusable. I really like the interface and overall concept, but it is honestly just about unusable as things are.

The Roon interface seems to be constantly working. If I try to do “View All” in the overview interface, it takes many seconds to scroll between pages of albums and probably minutes to fetch all the album art for each page. I tried setting the memory cache to largest available in the hope that would help but it doesn’t. Can you help please?

I’ve also tried doing the same with a wired Ethernet connection and get pretty much the same result - possibly slightly better but still more waiting time than doing time.


Give it some time to finish importing and analysing your music…you system is only barely above minimum spec and is probably going to take a few days to scan everything. You will probably see the spinning icon in the top right of the roon screen…click that to see what’s going on.

1 Like

It might be the Analyzing phase that is the cause of the issue, but it could be the Intel HD Graphics/OpenGL issue that is at play here.

One way of checking this would be to turn off the Analysis temporarily (in Settings/Library/Background Audio Analysis Speed) to see if that removes the issue. If it doesn’t, then I suspect the graphics issue to be the cause of the problem.

1 Like

It’s had more than a month already!

And thanks for the prompt reply btw!!
When you say “barely above minimum spec”, what aspect do you mean? I can easily add more RAM if that would help. Upgrading the CPU would obviously be a bigger thing.
Can you help me understand the Intel HD Graphics issue please? And whether there’s anything that can be done about that.

It’s currently doing a database a database update for your new software release, so you’ll get peace for a while until that’s done!!

My bet is that you’re being bitten by the Graphics driver issue - an interaction between some versions of the Intel driver and the OpenGL library that Roon uses for its UI. This issue strikes on a small percentage of PCs using Windows and Intel HD graphics hardware.

One possible workaround, if you can’t find an alternative version of the graphics driver is to try the 32bit version of Roon on your Sony. With your size of library, the 32-bit version of Roon should be OK - but the only way to find out is to try, I’m afraid.

Yeah, that won’t help making things fast.

It probably wouldn’t make things that bad, and @Geoff_Coupe is probably on the mark with the graphics driver, but just a thought to rule that out: your system, or at least Roon’s database, is on an SSD, right ?

Good point about the need for an SSD - I missed that.

Hi. It has an SSD. It’s currently rescanning files (24837 of 53574. Why do you think the 32bit version might run better? I’m running a 64 bit version of Windows btw. I didn’t mention that.

Because, for some unknown reason, the graphics driver issue doesn’t seem to affect the 32bit version of Roon.

You can try it and see. Uninstall your 64bit version of Roon (leaving your Roon database and settings in place - you’ll see this option during the uninstall process) and install the 32bit version.

Are you able to try a remote interface on a tablet/phone/other computer?
Do you get the same issue?

I’ve not managed to get a remote client to connect - tried both my mobile (Android) and a Windows client. I assumed that was either because Roon is so unresponsive or because of some firewalling problem (although the Windows client was connected to the same Ethernet so that ought not to be true unless it’s the Windows native security stuff). I just decided not to put any time into that until I get Roon performing adequately.

My experience has been that you need 64bit roon at about 110k tracks. But all is not lost because you can run 64bit roon on the core and 32bit roon on the remote even on the same machine. There is a post somewhere describing how to do that.

The database has completed now but the responsiveness is the same. I tried to upload a video to show you but those don’t upload. Basically, it will scroll maybe one screenful then stop for about a minute, then do another page or two.

What would you like to do first? Are there some things you would rather I do go before going to the 32bit change?

Also… I tried connecting to the Core from my Windows laptop again - it sees the other machine and repeatedly tried to connect but fails.

I uninstalled Roon on my laptop and reinstalled with the 32bit version but it still fails to connect.

Waitasec… what machine is that core running on, exactly ?

If it’s not your Windows PC, and you have a drive lying around with enough space on it to house your library, would you maybe consider exporting your library to it, alongside your database, and connecting that to your Windows computer ?

(the idea here is that if RoonServer is running on your NAS, and it’s underpowered, it doesn’t matter how powerful your PC is, because you’re asking your NAS to do the heavy lifting)

It’s running on a Sony all in one PC of the direction I described. The Synology NAS is just acting as a file server. The Sony has an SSD installed.

I just restarted Roon on that device and it’s going through the update again. It completed adding the files very quickly but says it’s scanning. That’s more completed as well apparently. But the lack of responsiveness hasn’t changed. It’s not just that it doesn’t scroll. It’s completely unresponsive.

Sorry… my predictive text is adding a few wrong words. Hope you get the sense of that last message