Update 2.0.25 broke Roon remote connections. My solution (to help others)

I received the 2.0.25 update last night and immediately all my Roon remote apps on my IPad, Android phone and Fire Tablet stopped connecting to the updated server (formerly core) on my Windows setup. The remote apps could see the server, as indicated by the “connecting” message, but wouldn’t connect. Reboots of all devices and my router did nothing.

After discovering that connections would complete if I disabled the Windows Defender firewall on my core machine I did some nosing around in the firewall settings. It turned out that two instances of roonappliance.exe were now blocked by Defender. This was not the case prior to the update.

The solution was to allow inbound connections for roonappliance.exe in Defender (go to inbound rules>properties and allow the connection for roonappliance.exe).

I suggest that anyone who has a similar problem after the update check to see if this is the issue.



Thank you for your post and for solving this problem. I too had the same problem of Roon Control apps (on iPhone, Windows PC, and iMac) not being able to connect to Roon Server (formerly Roon Core) following the 2.0.25 update. Roon Arc was also unable to connect.

Roon Control did work OK on the PC that was running Roon Server but it could not see any of my network audio zone endpoints (Meridian MS200’s and Meridian 818 ID41). Roon Control could however see the computers that were running Roon Control apps (notwithstanding that the Roon Control apps could not see the Roon Server) - so I could for example force playback on a remote iMac (by choosing that zone from Roon Control on the server PC) but was unable to control Roon directly from that iMac itself!

I assumed it was a firewall issue but had no idea how to fix that, so thank you for your suggestion of allowing inbound connections for Roonappliance.exe. When I investigated, the two inbound rules for Roonappliance.exe for the Private Profile (one for TCP protocol and one for UDP protocol) were both set to ‘Allow’ but the two inbound rules for the Public Profile were both set to ‘Block’. I changed both of these to ‘Allow’ and the Roon Control apps and Roon Arc all started to work as normal again. Also, Roon Control can now see all the Meridian network endpoints.

My question @support is why the Public Profile firewall settings need to be set to Allow when working within a private local area network in my home.


1 Like

I’m on a mac and didn’t have any firewall issues, but both my Home Assistant and Stream Deck lost their connections to control my library. Previously, the Stream Deck Roon plugin was set to use port 9300, which seems to have changed to 9330. I was able to reconnect the stream deck by changing the port, but had to remove & re-add the integration in Home Assistant.

Im having same issue running Mac, once screen sleeps Im unable to stop playback or anything, have to relaunch remote app.

1 Like

For me this is intermittent - sometimes it happens, sometimes it is fine. I have a separate topic about this issue with screenshots Issues with Roon Remote 2.0.25 - #24 by fietser - when you encounter the issue, how does your screen look?