Update on 9/21/21 ends with There was an issue loading your database

Roon Core Machine

Non-brand PC.
Processor is Intel(R) Core™ i7-4770 CPU @ 3.40GHz 3.40 GHz
16 Gb of RAM.
Windows 10, latest update

Networking Gear & Setup Details

Latest Comcast Xfinity Modem/Router

Connected Audio Devices

Wired to PS Audio Bridge II by Ethernet.

Number of Tracks in Library

350,000 Tracks

Description of Issue

I’ve never had a Roon malfunction. When I turned on Roon app this morning it said there was an update. I updated my PC, Android tablet, and Android phone (the tablet is the primary remote, but I use the phone as a backup, for instance if the tablet isn’t charged. Been doing this for 2 years).
At the end of the update I got the “There was an issue loading your database” message. Per your instructions, I did the roon_old thing and downloaded Roon from your website and reinstalled. Same problem. And I can’t get past the initial screen to follow suggestion of logging in and loading database from a backup. Following one suggestion, I uninstalled Roon from the tablet and reinstalled it. It tried to locate the core and was unable to. I have recently, a few days ago, bought and installed HQ Player. I love it, the sound is incredible. Could this have something to do with the problem?

Hello @Julius_Moshinsky,

Thank you for letting us know of the problem you’ve encountered and the steps you’ve already taken to remedy it. We appreciate the effort :pray:

When you say you can’t get past the initial screen, what are you seeing? Could you please share a screenshot?

Here is a screenshot of the initial screen I can’t get past, requested by Rebekah.

So I got pro-active and deleted Roon and databases. Reinstalled at 4pm yesterday, and today the databases are 90% finished building.

Hi @Julius_Moshinsky

I’m so sorry to hear about the trouble you’re having loading the Roon database. Typically, problems loading the database mean that it may have been corrupted at some point. We have more information about what can cause corruption and steps that you can take to recover your database here:

If you’re having any issues after following the recovery steps above, please let me know!

As an aside, right now our team is working on some changes that will help our customers detect corruption when it’s happening. If you don’t mind, I’m hoping you could take two minutes to send us your corrupt database. That way our team can analyze the type of corruption and prevent similar cases in the future.

Here’s how you can help:

  1. Follow the recovery steps above
  2. Zip up your Roon_OLD or RoonServer_OLD folder (right-click it and select “Compress…”):
  3. Sumbit the .zip file to us through our Database Corruption Issues portal

Your participation will go a long way in helping our team improve corruption detection, so we’d greatly appreciate your help. :pray:

Thanks for your attention! My reinstall of the application and creation of new databases happened overnight and the new install is working without a glitch. Except trying to get HQPlayer and PS Audio DAC to talk to each other. If you look at my topic, you can see that someone is trying to help me. If you know anything, please help.

1 Like

Hello @Julius_Moshinsky,

Thanks so much for letting us know right away that resetting your database and reinstalling Roon resolved the issue for you.

Could you please share with us how things stand on enabling the HQPlayer and your PS Audio DAC?

1 Like

Yes. Roon is working fine now, with ongoing issues that I will clarify and bring to the community.

With respect to HQPlayer, it was a no-go from the start, apparently. My system uses the PS Audio Bridge II as its Roon connection. It turns out that HQPlayer only works with a USB connection. Read Jussi’s explanations from my Community posting.

I use the Bridge because I wanted to avoid a USB connection, even asynchronous. HQP wasn’t listing my PS A Perfect Wave II DAC or the Bridge. That’s because even if you use an ethernet connection, there has to be a USB Connection from the host computer to a device converting it to Ethernet. That would cost more money and possibly degrade the sound.

If Roon indicated that HQPlayer was for USB connection only, I didn’t catch it. I guess most people use USB anyway. $260 down the drain (I hadn’t previously known that Roon could play DSD-to-PCM, which is great, but when I tried that during the HQP trial, I assumed that it was the HQP doing the conversion, and that it was working–thanks for that great feature, though, many files I can get only as DSD64 and not wav or flac).

Thanks again for your attention!