Update ROON from build 1234

I have had the lost control of Sonos problem. haven’t tried to play sonos via roon for a while. It still doesn’t work for me although i see that the problem is generally fixed. All Sonos gear is S1. They are on 11.8 which is declared to be up to date. Roon is on 2.0 build 1234. This sounds out of date. However, on the Roon about tab I am getting a never-ending checking for an update messge. True for both mac and Android versions of roon controller. On the assumption that Roon needs an update how do I force this to happen please?

What are you using for the Roon core?

I have Rock installed on a NUC

In this case go to http://rock in a web browser and click the Reinstall button for Operating System. This will also update the Roon Server Software

Many thanks for the help. I will give that a try. I operate on the limits of my knowledge with this stuff!

This should be safe, but make sure you have a current database backup as you always should.

Plunged in, but it seems to have worked. Many thanks for your time, very much appreciataed.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.