Update to Roon 1.8 Build 880 corrupts my Roon Core database

And no apology and excuse is it’s our hardware. It’s a joke

1 Like

This aspect of the ‘official’ responses to the reported problems I find disingenuous. Of course, hardware problems could in some cases be to blame. But there can be software problems, too. And the software library used for data persistence (LevelDB) has a reputation for having bugs that can cause data corruption. So no cause can be simply ruled out. Having read through many threads and posts it seems to me that those affected are users of any supported platform—yes, there are affected ROCK users, too. There are users with servers set up not so long ago. Others have been running on the same hardware for several years.

I myself am lucky not having been affected, despite very frequent power cuts and operating without UPS. Until now, my 18 months old Roon server has resisted corruption.


Just like to add my voice to Roon fails to work after update, running on nuc I5 with RoPieee and Google endpoints. Is there fix in the works?

Well … I tried backups… no luck there… there is a problem with your database despite going back more than a year. So starting fresh I now have no audio devices. Now what??

1 Like

Build 882 has just been released.
Try downloading it and see if it helps on your setup


Hi all, we just release Build 882 that fixes a few issues affecting some folks in this thread. Please read the release notes for more details!


worked for me. thx for the update!


On a fresh install I see no audio devices. Everything appears fine though and any remote devices connect but no audio devices there either. When I shut roon down and restart I;m back at the same place. There was an issue loading your database.

Can you confirm you’re updated to 882 in Settings > About?

Why did I have to browse to find this? Anything like this related to this 880 disaster should go by email to every user and be featured and highlighted on the community/web page


If you’re talking about “Facebook,” a lot of us wouldn’t get near that. Otherwise, what community web page are your referring to?

1 Like

Build 882 works seemingly OK now on my Windows 7 box. I was able to restore fresh and see audio devices. I went and restored my last database backup under 831 and seem to have gotten back everything (except the local WSAPI audio - I had to set it up again, but it was there /to/ set up).

Just played a song. I don’t know if everything’s back right, but much better so far. Thanks for working this issue!


Latest update 882 seems to have fixed my issues, thanks


just got an update and it seems my issues are resolved… even restored a backup … fingers crossed



Same problem with the 882 : i restored a databse and after : 0 albums, 0 artist…


The new version solved my problem (Roon stuck at the pulsating Roon logo) as well.


Same issue stays with build 882, empty library and no devices, failed to load database after backup restore.

I’ve just lost years of database updates. Utterly ridiculous.


Submitted B880 logs from my primary ROCK server.
This is for a newly created Roon Core database using a restore of backup of an existing B831 image.
I also have a RoonServer_old on this NUC I can reinstate, if required.
Now going to try the B882 release on this NUC/ROCK server.

Update B880 updated to B882 on this ROCK server and the Roon Server started up, the Library was correctly present in the Roon Remote app briefly, but then the ‘Database Corrupt message’ displayed and Roon halted.
Now trying a Restore of a past Backup on this Build, to see if the update process manages to do anything with a past B831 backup image.

I am also building a fresh B880/B882 Roon Core database on my backup ROCK server, so I have something operational for the Christmas period, but without the existing Playlists, Library Tagging, and organisational of my previous Library.

Further Update The restoration of a B831 Backup into a B882 environment, fails in exactly the same way as with the B880 Build, i.e. An update is applied to the database once restored from the Backup, and then Roon Server on startup halts dead with a database corrupt message.
No no improvement with the B882 build and at present no solution for an existing Roon Core database prior to B880/882.

Will submit the logs from the B882 instance - but will probably tell the same story as the ones from B880


That they used a shaky, open source database platform without having some sort of repair option available to users to fix their libraries in the event of corruption is either lazy, incompetent or both! This possibility of total failure has been flagged for years by various users and it has been ignored. Any decently written update to Roon would have rolled itself back DURING THE INSTALL if the new version found something amiss or incompatible that needed to be addressed rather than the damn thing going ahead regardless and leaving users with nothing to play!