Updated to build 923 on Qnap, now no access to Qobuz

Roon Core Machine

Qnap 473, 8Gb RAM. Roon on internal SSD drive as per recommended specs.

Networking Gear & Setup Details

BT Smarthub2 router, wifi controlled via Netgear Orbi

Connected Audio Devices

Lumin U1 mini, various Sonos, iPhone 13

Number of Tracks in Library

c. 22,000

Description of Issue

Was listening to Qobuz on iPhone via Roon last night having recently taken out a trial of Qobuz. Up popped Roon update available message so updated. Immediately Qobuz was inaccessible. Went to Services, Qobuz showing login button, not connected. Entered login details and got “unexpected error, check account details” message as per screenshot below.

I can login to Qobuz through their website as well as their app and also through the Sonos app, so it definitely seems to be a Roon related problem. Tried again this morning, same issue.

Hi @John_Armour,

Thank you for the report, we received a remote diagnostics report from you Roon Core today. That report indicates that there might be a connectivity issue. Could you, please, provide more data about your network: any VPNs, firewalls enabled on the core on the router?



Thanks for the quick reply. I do have a VPN running on the NAS though haven’t previously had any conflict with Roon that I am aware of.

I can try disabling it to test whether Roon will the work.



I stopped the VPN, opened up Roon and tried to login to Qobuz. I got the same error although it took a lot longer (say 30 seconds vs. almost immediate) for the error to appear.

There is no firewall running on the NAS.


Now sorted - with the VPN running.

Last night when this first happened I stopped and restarted the Roon core on the NAS. On restart, the app remained grey for a minute, much longer than normal. It did seem odd at the time but it did finally appear as normal so I thought no more about it as it opened on my phone and although I still could not access Qobuz, I could get to my own library.

However, following my last reply a of few minutes ago, I restarted the VPN then stopped and restarted Roon once more. This time it restarted in about 5 seconds. Tried Qobuz and it now works as normal.

So no idea what might have happened but it does look likely that there was some connectivity problem when I first restarted Roon.

Will remember this in case it happens again.

Please close this query unless you think there’s any additional issue worth further investigation.

Many thanks


Thank you for the reply, @John_Armour, glad that you were able to figure it out. Please, let us know if you have any problems.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.