Updating Library new settings is stuck

I made one change in settings and Roon started to uppdate the Library.
Now it is have been stuck at around 70% for at almost 24 hours .
I run core om a NUC (i3/16gb/w10) Processor is running at 30%. Audio analyse is turned off, no backup is running now but is scheduled every 24 hours. No Audio is playing.

  1. If I terminate the core app Will at continue to update the Library?
  2. How do I know/check that the Library has been completely updated ?
  3. Is there a risk that I May need to restore a full backup ? How do I check when I changed the settings - so I choose the right backup .
    It was 2 or 3 days …,dont really remember


My local files / library are 5600 albums

What setting did you change? If you mean that you made a change in the Import Library settings, then Roon will indeed update your library. This is expected behaviour.

However, it should not take 24 hours to reach only 70% completion.

You should shutdown or reboot your Core gracefully - don’t force a shutdown or pull the power. Use the Power Off button on the Web Administration page.

Once rebooted check to see if the import process has completed. If it has not, or does not complete within a reasonable time, then there may be a music file that is causing the problem. In this case, Support will need to pull logs to check for the problem file.

I changed one import setting. One tag-related setting . i dont remember exactly which setting.

The updating started as expected but only to 70%.
The updated It has been 70% complete for 24 hours .

I have not started any import process .

I dont understand ”the web administration page”. The core is a Windows application.
I just close it with the X in the top right corner or terminate it in task manager ?

When i start again …What Will happen ?
Will it Continue the process at 70% and try to complete it ?

  1. I closed the Core Windows app and restarted the NUC-machine.
  2. I started the Roon Core app and it started scanning the storage and updating the library
  3. When I closed the app it was about 70% complete have run for many hours but after restart it took only a minute to complete the remaining 30% …hmm

Question: How can know/verify that all my library have been updated with my new import settings?

Sorry, I just saw the NUC and missed the w10 suffix - I assumed that you were using a ROCK/NUC setup. My mistake.

So, since the import has completed, we can assume that your library has been updated. There’s no “verify” function available.

ok. thanks.It seems to have worked with the restart.

Can see/check what import settings (and other settings) for a specific backup ?

You can close this. Thanks for quick response.

No. You’d have to restore the Backup to see what settings were in place at the time when the Backup was taken.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.