Upgrade to 1.7 511 doesn't work

Core Machine (Operating system/System info/Roon build number)

currently using 1.7 build 505 on Mac mini 10.15.2

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Tried updating core 5 hours ago. Click update all and Roon downloads the image and quits Roon and sits. I start up Roon and keep getting asked to update to 511. Get info states that the software gets updated right now but Roon still shows build 505 instead of 511.

Hi @maximasr,

If you download the latest version of Roon directly from our downloads page does this work for you?

2 posts were split to a new topic: Trouble updating Mac to B511

Did that, same issue. Expanded the dmg file. Are you sure what’s on your website is build 511? After I load the latest download, I startup Roon and its build 505

Hi @maximasr,

I just had the team verify that the correct version is on the download site. Can you try once more and let me know if the new version is downloading for you now?

Now it worked, got build 511 on my MacBook Air Early 2015 by downloading it from website.

I tried it again. If I use the update all from the main Roon screen, it didn’t work. I downloaded the app from your website AGAIN, and then ran the dmg file, it worked this time. The dmg files I downloaded yesterday always downloaded build 505, now it’s build 511.

Hi @maximasr,

I’m glad the download from the website is working for you now! Please let us know if you have any other questions or issues. Happy listening :headphones:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.