Upgraded to Roon 2.0.5 - Local files are now unavailable

Roon Core Machine


Networking Gear & Setup Details

Latest Comcast router - Intel WiFi 6 AX201
Nucleus+ is connected via ethernet

Connected Audio Devices

iPhone 12 – iOS 15.6.1 – 128G

Bluesound Pulse Flex 2i

Bluesound Pulse Flex

Bluesound Pulse 2

Auralic Aries

Bang & Olufson Beosound Stage

Sonos Roam

Number of Tracks in Library


Description of Issue

Hi - Last night I upgraded my Nucleus+ and remotes to Roon 2.0.5. Things were working fine prior to the upgrade, but now all my music appears to be “unavailable”. My collection is all local on a new SSD drive and I do not utilize Qobuz or Tidal. I tried rebooting Roon but the music continues to be unavailable. - Thanks

Is the SSD internal to the Nucleus+ or an external USB drive?
Can you post a screenshot of Settings > Storage?

Thanks, Geoff. It’s an external USB drive:

Is that external drive in NTFS format? If so, you may be the victim of much less permissible NTFS drivers in the Nucleus’ Linux kernel. Take the SSD to a Windows machine, mount it, UNmount it gracefully, and return it to the Nucleus.

And in the future: if you need to stop the Nucleus, do it from the web interface instead of yanking the power cord.

Thanks, Paul. Yes, the external drive is in NTFS format. I have followed the steps you outlined. When I attached the drive to a Windows laptop, it was able to mount correctly, and I was able to access the content. I then reconnected it to my Nucleus and powered it back on. Unfortunately, all of the music on the drive remains unavailable.

You may have to run chkdsk on the drive while it is connected to Windows:

Make sure that you then follow the correct procedure for removing it:

And when connected to the NUC, power it down before unplugging the USB

Roon has always recommended using exFAT and not NTFS for external USB storage to avoid problems like this

Even then, safe removal is very recommended


Thanks, Suedkiez. I ran chkdsk and that appears to have solved the issue. Thanks for your help!

I had missed the recommendation for formatting in exFAT vs. NTFS. I have never removed that external drive, so I’m not sure what happened. At least it’s resolved for now.


Based on my reading of other posts by Roonlabs on this matter, it seems to me (but I don’t know) that the relevant “dirty” flag in the filesystem, which can cause the refusal of mounting the disk with the new and safer driver, might have been caused by RoonOS itself in certain cases. Not sure. In any case, they are working on a better solution.

Not only with Roon, NTFS is a problematic filesystem for external disks because these issues occur all the time.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.