USB DAC Stuttering / Freezing

Core Machine (Operating system/System info/Roon build number)

Windows 10
Dell XPS 13 (2019, 16gb ram, Intel i7-8565U, plugged in)
Roon 1.7 (511, 64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Topping DX3 Pro DAC (USB - brand new!)

Description Of Issue

Hi,

I’m having a problem since adding a USB DAC to my Roon system. The audio breaks up fairly regularly (say 1-2 per album). Often, it just stutters and resumes playing. Sometimes it stops completely and I have to manually restart the track.

Other audio applications on my system (MediaMonkey, Foobar, VLC) don’t seem to present this problem.

I’m not sure if there’s a way to generate a log for someone to look at?

I suspect it’s something to do with Windows 10 set-up not prioritising audio output via USB? (I never had this problem using system output or Chromecast Audio.) But as it only happens in Roon, I wonder if there’s a way to get them to play nice?

The system is well stocked for RAM. CPU and memory use in Task Manager tend to top out at 50%, with CPU usually at about 20%.

Thanks.

Hello @bjg,

Welcome to the forum and thanks for your report!

I have a few thoughts/questions:

  • What kind of media exhibits this behavior? Are you playing local library tracks, TIDAL tracks? Does this occur only with specific sample rates/bit-rates?

  • Have you tried using a different USB cable connecting to the DAC yet? Sometimes USB cables are defective so it’s good to rule this one out.

  • What does your Signal Path look like when this issue occurs? Can you please share a screenshot?

Hi @noris,

Thanks for the speedy reply.

Sorry, I meant to add these details last night on my original post but got distracted!

  • Yeah, I’m mostly playing local tracks – 90% 44.1 / 16 FLAC, some 320kbps mp3s and a TIDAL album every now and then. It doesn’t seem to matter.
  • Yeah, I’ve tried using different cables and ports. I even bought a USB-C to USB-B plug to go directly into the DAC (which came supplied with an older plug that had to go through my USB-C hub). Again, no difference.
  • And, signal path:
    image

HI @bjg,

Thanks for confirming the above. Let’s take a look at diagnostics next.

Before I go ahead and enable diagnostics mode for your account, can you please reproduce this behavior a few times and note the exact local time + date + track this issue occurs on?

E.g. Played Dark Side of the Moon at 12:51PM on 2/14/20 and it had stutters

Ok. Will do.

1 Like

Hi Noris,

I’ve noted a few hiccups…

14/2/20
8:01PM - Stutter - Vladislav Delay - Huone (FLAC)
10:01PM - Stutter - King Krule - Supermarche (MP3)
10:32 - Stutter - King Krule - Underclass (MP3)

15/2/20
11:57AM - Stutter - Tennis - Need Your Love (TIDAL)

17/02/20
12:33PM - Stuttered & Stopped - Bohren - Patchouli Blue (FLAC)

Thanks

1 Like

Hi @bjg,

Thanks for letting me know those timestamps. I have activated diagnostics mode for your Core and what this action does is automatically upload a log-set to our servers for analysis.

I can confirm that the logs have been received and I have requested analysis on the logs from the technical team. As soon as I have further information to share, I’ll be sure to let you know.

Also, although I don’t think it will affect your case specifically here, we just released a new version of Roon, please try upgrading to the latest one and if there’s any change in behavior do let me know, thanks!

Thanks! Updating now…

Hi @bjg,

Was there by any chance any change in behavior with the latest update?

I spoke to the technical team regarding your logs and we are seeing the following traces in your logs:

02/17 14:08:55 Trace: [RAAT::DX3 Pro] [lua@000000001CF5B268] [127.0.0.1:60430]  SENT [14] {"time":241986000,"status":"Success"}
02/17 14:08:55 Trace: [RAAT::DX3 Pro] [output/wasapi] [5- DX3 Pro] starting playback: now (200000000ns) + ns_per_buf(100000000) = 300000000ns > 241986000ns streamsample=0
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 3459 samples at 15390000 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15393459 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15397869 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15402279 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15406689 [2]
02/17 14:14:44 Trace: [RAAT::DX3 Pro] [lua@000000001CF5B268] [127.0.0.1:60430]  SENT [13] {"samples":21099,"status":"Dropout"}
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15411099 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15415509 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15419919 [2]
02/17 14:14:44 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15424329 [2]
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15428739 [2]
02/17 14:14:45 Trace: [RAAT::DX3 Pro] [lua@000000001CF5B268] [127.0.0.1:60430]  SENT [13] {"samples":22050,"status":"Dropout"}
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15433149 [2]
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15437559 [2]
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15441969 [2]
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15446379 [2]
02/17 14:14:45 Warn: [RAAT::DX3 Pro] dropout of 4410 samples at 15450789 [2]
02/17 14:14:45 Trace: [RAAT::DX3 Pro] [lua@000000001CF5B268] [127.0.0.1:60430]  SENT [13] {"samples":22050,"status":"Dropout"}

Roon is trying to send the audio to your DX3 zone, but the device appears to be dropping these packets.

Furthermore, we did a bit of investigation into this DAC and from the online sources we found, you are not the only one with similar issues regarding this DAC:

Topping is not a Roon Tested/Roon Ready DAC, and we don’t have this device in-house to confirm similar behavior on our end, so I would suggest that you reach out to Topping support as well and ask for their assistance regarding this issue.

Thanks. Those posts don’t quite describe the problem I’m having. However, they did lead me to download the official ASIO driver. So I’ve installed that and I’ll see if it helps. It might help if buffering is the issue with the packet drops.

1 Like

Hmm. I’m still getting this problem. It is definitely worst in Roon, though it happens occasionally in other programs. (I suspect because Roon uses a lot of memory on my PC – more than other music programs.) Are there any tips on, perhaps, increasing buffer size or something to stop the dropped packets? I’m not quite clear on how that stuff works.

E.g. see here, using practically 1gb, multiple times the next closest process (which is Acrobat with a lot of PDF files open for a project):
image

Hi @bjg,

If this behavior occurs outside of Roon, that’s even more of a reason to reach out to Topping directly for support.

You could try increasing the buffer size but I can’t say if it’ll help at all. You can increase it by going to Roon Settings -> Audio -> Cogwheel icon next to zone -> Device Setup -> Show Advanced -> Buffer size.

1GB of RAM usage is normal for Roon. The way Roon works is similar to a video game, it uses OpenGL to display the interface and would use a comparable amount of RAM to processing a game engine. I don’t believe the RAM is the limiting factor here, but rather the DAC itself.

Thanks. I’ve switched Roon to use my Chromecast Audio plugged into the DAC with an optical cable, rather than running straight from Windows 10 to the DAC with a USB cable. That has fixed the stuttering issue. So there’s clearly an issue somewhere between Roon / Windows 10 / USB / DAC.

1 Like