USB device does not get recognized after being reset

Hello support team,

I’m currently evaluating Roon for a multi-room environment at home, and I’m finding a key issue when trying to integrate with my (USB DAC)/amplifier which makes it basically unusable in my home. Hopefully this can make its way into a fix quite quickly…

Core Machine (Operating system/System info/Roon build number)
Linux (ubuntu 20.04 LTS) / kernel 5.4.0
Roon 1.7 build 555

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
QLogic Corp. cLOM8214 1/10GbE

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Rotel RA-1570 over USB (ID 278b:3001 ROTEL Rotel PC-USB)

Description Of Issue
When the amplifier is turned off, the usb device is disconnected.
When the amplifier is turned back on and the USB device re-appears it is not connected automatically to Roon, instead Roon shows is as “Device not found” until manually retried.

Expected behavior
When the device comes back online, it becomes immediately available in Roon without manual intervention.


Hello @Shujaa_Hooves, and welcome to the community! Your DAC is connected directly to the server, right? If so:

  1. Does the server recognize the device when it wakes up?
  2. Have you reinstalled drivers for your DAC? Are you using Realtek or ASIO drivers?
  3. Have you rebooted the PC while the DAC was connected and powered?

Let me know and we’ll go from there!

Hello @nuwriy, and thanks for the quick reply !

I’m realizing from your questions that I may not have been 100% clear :slight_smile:

  • I have a Rotel amplifier with integrated usb dac
  • The amp/dac is connected using USB to a linux server (x64, an actual server) that runs roonServer
  • When the amp is turned off, the dac is powered off and gets “disconnected” from the server, like if I pulled the usb plug
  • When I turn off the amp, it removes the dac from the Roon Server and shows as ‘not found’, which is entirely expected
  • When I turn the amp back on (equivalent to me re-plugging the dac usb cable) I expect Roon the re-enable the device as an audio output so I can play my music immediately to it, but I observe that the device stays shown as “not found” until I manually re-discover (gear icon > retry) or re-load the roonServer or reboot the server machine

1 - If I restart the roon-server / reboot the machine the USB dac is recognized successfully although I never turn off the server, ever :slight_smile:

2 - Drivers are stock linux kernel drivers for a very standard USB-dac protocol. (usb-snd)
T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 46 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ef(misc ) Sub=02 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=278b ProdID=3001 Rev=01.03
S: Manufacturer=ROTEL
S: Product=Rotel PC-USB
C: #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=01(audio) Sub=01 Prot=20 Driver=snd-usb-audio
I: If#=0x1 Alt= 0 #EPs= 0 Cls=01(audio) Sub=02 Prot=20 Driver=snd-usb-audio
I: If#=0x2 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=usbhid

3 - Yes, I have, if will recognize the dac when RoonServer starts

Thanks a lot for your support

Perhaps your amp’s off is not a real off and there is enough of a power trickle to confuse things. Try unplugging your amp from the power completely, wait a minute or two, and then plugging it back in, does it exhibit the same behavior?

Hey Rugby,

Coming back from a business trip and updating all my regular stuff :slight_smile:

I’m wondering if an update came during my trip as it now retries the amp immediately on power-on even with a roon client open, which was not the case before.
In any case, as long as it works… Although I still suspect that if I run a fresh install I might stumble on the issue again, but in ths case I’ll let you know :slight_smile:

Thanks for hearing me out !

If it is working, I say “leave it alone”. And, yes, there has been an update in the last two weeks, I think.

Anyway, glad to hear it is working!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.