USB disconnection woes with Expert line (200)

I’ve been noticing that when I switch to the USB source on the Expert, whether I do it via the front panel button or via the RS232 protocol, the 200 freaks out and disappears from USB and then shortly after reconnects.

Is anyone experiencing the same? Any way to work around it?

I’m trying to get RS232 based automatic source switching working, but this makes USB very unstable :frowning:

This has nothing to do with Roon either… I can reproduce this when not running Roon and without playing any audio.

Hi - it happened to me a couple of times when I changed the source from USB to Ethernet - on one occasion the USB option completely disappeared! I had to then re-install the Devialet driver to get the source to work properly. Btw I am using Windows 10 to run both the software. I suspect the Devialet driver needs another update. Suffice to say, I am not playing around with the source option for now.


I’m running on a Mac, so no driver for me.

I found the USB INIT feature in the configurator, which seems to be exactly what I need to be turned off, however it doesnt seem to be turning off even though I have it set off.

Anyone successfully turn it off? I’m using firmware 10.0.2, but I also tried 9.0.1. Neither seem to have the ability to turn USB INIT off.

I can’t say I’ve thoroughly tested each scenario but here’s what I think I’ve observed…

If I change inputs on the Devialet while music is streaming via Devialet AIR, it can kick into white noise (a known issue with AIR, even the new v3 beta). If I do so while using USB input via a Sonore uRendu, it may have difficulties reconnecting. I have had to actually restart the uRendu. But I don’t think it happens 100% of the time… I should say that it is never a problem changing inputs as long as no music is streaming at the time.

I suspect that the AIR and USB problems are different issues, but who knows. My solution is to avoid changing inputs while music is streaming regardless of how I stream.

My experience is the same as mdconnelly. If something is streaming to the Devialet and I change inputs, the Devialet will freak out for a bit.

Danny does the usb audio stream begin before the RS232 command is sent? Maybe if you set it up to begin streaming after the switch it would solve your issue?

If Devialet would just become Roon Ready (possibly with the new streamer board?), then this problem, and the direct control of volume and source selection, would likely be solved.

If I’m playing music to the Devialet (via microrendu USB) and change input, Roon seekbar keeps moving and it looks like music is still playing. It’s only when I toggle back to USB that Roon gives a transport error and after a few seconds reconnects but in paused mode.

@danny, how have you verified that USB_INIT isn’t setting?

I checked the dp_cfg.txt file and it says:


I changed the name of the config name, and it showed that name when booting. I noticed their configurator app always resets the value if i revisit the tab. :frowning:

Will check mine, I remember this feature being discussed and am sure people had it set for various reasons so it may be a new bug. The Configurator does have it qwerks from time to time :wink:

[edit: Hang on, so you’ve set it off and it’s showing as off in the config file as it should, but it’s not working as expected? How do you verify that?

Actually, re-reading this all it seems like it has set properly. If it’s in the config file its set. There are various settings that sometimes revert to defaults when you go back to the configurator - and you never know what they will be as Devisket never tell anyone they’re changing it - that’s just one of its qwerks. But if it’s written to the file its set. ]

  1. i set it off
  2. i verify the config has it off
  3. i verify the config’s name is loading on boot
  4. i switch from optical to usb and notice that in OSX the devialet disappears from the audio devices list for a moment and then reappears (this is caused by the devialet doing a usb disconnect/reconnect)

my reading into the feature is that USB INIT is the setting that should cause this disconnect/reconnect feature.

I want the USB connection from the Devialet to my Mac/PC to be stable as I flip between USB and optical (or any other source).

1 Like

Mmmm, I don’t think I’ve ever managed to get that outcome with either setting.

In various discussions around Devialet and the microrendu, Sonore’s impression was Devialet have done something weird with their USB implementation and/or handshake.

USB_Init Is quite a new feature. I think firmware 9. So not too much discussion about it.

the problem with the source switch is that the devialet disappears from the mac/pc, so if my roon extension tries to flip the source to usb, it freaks out and thinks you pulled the cable.

a moment later all returns, but audio wont be playing since it does not know that all of the events were part of 1 sequence.

I alos seem tk have an usb issue with my D200.

Since 2 months, roon does not recognize the devialet connected via USB after, I do not know exactly.

It could be after switching on the devialet in the morning or waking up my NUC. Either way, running roon on my tablet does not list devialet as a output device at all. Only restarting my NUC help roon to recognize my D200.

And the only thing that has changed since March this year is the update of my android app. I did not change anything on my d200, nor did I perform any updates on my NUC.

Any idea?

people have been noting this usb issue with the Expert on the Devialet forums… it seems to happen everywhere (NUC, Macs, etc). It seems the Devialet does not negotiate the USB initialization properly. The latest Expert firmware added a new option. It is called USB INIT or something like that. Did you try playing with that? You’ll probably have more luck on the Devialetchat forums as well, as this does not seem to be Roon specific.

1 Like

Funnily enough I am experiencing the same problem (very intermittent) with new beta AIR protocol on Windows - the option suddenly disappears if you
change the source to optical or USB - on one occasion the option re-appeared but simply did not work as in no sound, so I did usual uninstall and re-install of the program and bingo- it worked! - very annoying. As an aside I have noticed that the Devialet programmers have been quite active in chat forum on the beta testing for AIR which I think is encouraging - hopefully this can translate into other areas of their business.

du you think that introducing RoonOS could solve the USB issues with Devialet?

No, they are on the Expert side, not the Roon side.

Just watch your audio endpoints in Windows or MacOS if you have an expert connected via USB and you switch sources. Your OS will totally lose the Expert momentarily.

Practically speaking, the main issue I have with this is when using a grouped zone containing the Devialet (generally lounge grouped with kitchen). If I’m playing in the kitchen (grouped) and the Devialet is off, as soon as I turn it on Roon playback stops. I have to wait for the D to startup and then press play again. This is using the micro rendu, and the same would happen if toggling input.

I know it’s technically the Devialet’s fault, but it would be great if in the future Roon had a mechanism for uninterrupted playback in these type scenarios.

In terms of giving the feedback to Devialet, what is it technically doing wrong?
Hopefully you guys can send feedback too - it would be great if this could be fixed in a future firmware.

Like you say, it’s not just Roon that’s affected.

In switching to the USB input, they ‘reset’ the usb connection – my guess is that the USB subsystem is driven by something else than the rest, and this is a hardware limitation… but I could be wrong about the reason why.

I’ve made a support ticket with Devialet.

[New ticket open #58658]

I’ve also suggested they contact Roon and Sonore for further details since it affects both the rendu and the Roon application.

Will report back if I hear anything - more times than not Devialet simply thank you for your support ticket and close the ticket as ‘solved’.

1 Like

I’ve been told their engineers are too busy to contact anyone to discuss the issue, but they’ll bear it in mind for the future. I give up!
I really resent giving them more money for my pro upgrade, but it does sound good - that’s the annoying thing!