USB Ethernet adapter worked at first, then seems to have stopped working

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus V1.0/94C691115A93/Build Number 174

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Verizon FIOS wifi & ethernet cable router --> Actiontec Bonded MoCA 2.0 Ethernet to Coax Adapter (ECB6200S02)

Plugable USB 3.0 to Ethernet Gigabit 10/100/1000 LAN Network Adapter (ASIX AX88179 chipset Compatible with Windows 10, 8.1, 8, 7, XP, Linux, OS X/macOS, Switch Game Console, Chrome OS)

Endpoint DCS Network Bridge ethernet

My issue is that the USB Ethernet adapter (see above) connection does not seem to work after working once only - the first time. My Actiontec Ethernet to Coax adapter wired modem is connected to the Nucleus (via a pair of TPLink media converters for isolation purposes) with a Wireworld Starlight CAT8 ethernet cable. The first time I made the connection, the Nucleus appeared correctly in the Roon app with all music being found etc, but since that first time it no longer works. There still seems to be an internet signal passing through because all four lights on my TPLink ethernet media converter are still flickering correctly, but I cannot see the Nucleus in the Roon app. If I switch the ethernet cable to the ethernet port of the Nucleus, then the Nucleus shows up correctly in Roon.

Many thanks for your help.


Hi again:
I switched to a different ethernet cable Blue Jeans Cat 6 from the WIreworld, as I heard that has been a problematic cable for some Nucleus users. But now the problem didn’t go away, but in fact seems to have expanded to even the Nucleus ethernet port which does not work. I don’t see the Nucleus anywhere on my LAN anymore. Could it be the TP-Link fibre ethernet media converters that I use that the Nucleus doesn’t like? I read that a user who had trouble with the WW Cat8 cables also had trouble with the TP-Link converters too? Please let me know what you think I should do.

Hi @Hasan_Latif,

It would be best to try to simplify things as much as possible, confirm it works as expected and only afterwards try adding complexity back in.

I would first try to bypass all your USB/Coax adapters and connect the Nucleus directly to the router. Once you do so, does everything work properly then?

To do a quick check to see if the Nucleus is accessible in the network, you can try opening the Web UI for it and see if that displays the Nucleus info as expected.

Can you give that a try and let me know if it helps?

– Noris

Hi Noris:
Yes that does work. I plugged it into my main Verizon wifi router and it is visible. I used a Cat6 cable and not the Wireworld Cable to go straight into the ethernet port. I am seeing it via wifi, not via cable.

Next I tried putting in the USB Ethernet adapter and the Cat6 cable into that. And then I cannot any longer see the Nucleus. This adapter/WWcable combo worked once only out of the the USB port - basically only the first time I tried it today. I guess it looks like at least this adapter is implicated, right? Maybe the WireWorld cables somehow damaged it or something?

Have others had trouble with this adapter, and if so is there a better one to use with the Nucleus? Or maybe it is just the WW Cat8 cable that doesn’t work with it? I guess I could get another one and try it with my Blue Jeans cables instead of the WW Cat8 cables. Please let me know if that is what you suggest.

I would prefer to get my Nucleus to work in bridged fashion rather than with an external switch if possible. I believe that will be best for SQ. Do you agree?

I am not wedded to the WW Cat8 cables for sure, if they are the source of my problem. Nor do I feel committed to the TPLink converters, although I suspect these are not also causing a problem, or do you believe otherwise?

Please let me know what you think I should try next. Your help is much appreciated. Thank you



The Nucleus’ own USB port seems fine as I am able to see music on an external USB drive if I connect it via USB cable, while using the ethernet port with a Blue Jeans Cat6 to my wifi router.

Thanks again


From the peanut gallery, I would just plug both the Nucleus and the DCS into the same switch (not router) and be done with it. A low cost non-managed switch like a 5 port Netgear works great. Part of having such a high end piece of gear is that they are already taking care of cleaning things up, imho, no need to put all the extra stuff in between.

However, if you do want to fiddle, then I would suggest a couple of tweaks

  1. get one of the audio grade switches, plug the router, Nucleus and dCS into that.
    and/ or
  2. get the new sonore optical rendu / optical module and put them between the switch and the dcs.
    Nucleus > ethernet > Switch > ethernet> sonore optical module > fiber>optical rendu>dCS.

Hi @Hasan_Latif,

I would agree with Rugby here, you should be making use of the Ethernet adapter on the Nucleus itself and leave the USB -> Ethernet adapters out of the equation.

You can try the tweaks that Rugby suggested but only after getting the basic setup stable and working, and it seems that you are not a that point yet.

Unamanged switches work best for Roon because you don’t need to configure many options, they are essentially just plug-and-play. For some more reading materials, feel free to check out Sound Quality Guide and Networking Best Practices (<-both clickable links).

Do let me know how it goes in the simplified setup!

– Noris

Thanks @Noris and @Rugby. That’s pretty sound advice.

I guess since I am moving from a MacMini RoonCore to Nucleus, and the MacMini is running in bridged ethernet mode with no external switch in use, I had been wanting to preserve that advantage. Perhaps the Nucleus will give me other advantages that will overcome any loss of SQ due to using an external switch and perhaps lesser cables since it seems I’ll need to use my Cat6 cables and give up the Wireworlds.

A new switch arrives today, so I can work with the basic setup and then see if I want to move on from there.

Many thanks for your help.

1 Like

Noris, Rugby: Yes everything works very nicely with the new unmanaged Cisco 5 port switch. Also definitely sounds better than the MacMini so I am very happy with it all. And thanks very much for your help.

Interestingly the switch too does not like the Wireworld Cat8 ethernet cable, but works fine with the Blue Jeans Cat6.

And no problem with the TP Link fibre media converters. Those are working fine too with the new switch and the Nucleus. I have the pair of TP-Link converters positioned right after the Actiontec Bonded MoCA 2.0 Ethernet to Coax Adapter. BTW this Actiontec adapter is there to allow me to extend a coax connection to my living room from the Verizon fiber-optic FIOS box which sits in my bedroom.

At some point I may try the bridging approach too. But that can wait.

Another question if I may please. What are the power requirements of the Nucleus? I see 19V, but what is the current requirement? And is there any leeway on the voltage spec?

@noris, I do have another slight ongoing issue to check out please.

The USB drive on which I store my drive does not seem to be readily seen by the Nucleus even though it is switched on and working fine. I have to plug and unplug the USB plug a few times before it works. The USB drive is a G-Tech drive with mini-USB which I have connected using a Wireworld Starlight 7 USB USB2.0-to-MiniUSB cable to the Nucleus’ USB port.

Any thoughts about this? Thanks a lot.

Have you tried a standard USB USB2.0-to-MiniUSB cable?

@rugby, thanks for the thought. If the problem persists I will do that. Today and last night the Wireworld USB cable was behaving so I am keeping my fingers crossed.

Eventually I do want to move to a SSD drive. I expect that will be optimal, wouldn’t you say?

I might also eventually go back to trying the bridging of ethernet. But for now I am just very happy with the SQ improvements I am getting from the Nucleus.

Thanks for the help.

1 Like

I always try to plan in a period to just enjoy how things are before moving ahead with other tweaks. So, I’d say, if you are happy with the setup now, leave it alone, listen to the music, and crack a bottle of something to enjoy. :smiley:

1 Like

Hi @Hasan_Latif,

Glad to hear that you managed to get the system working with the unmanaged switch!

Generally, we don’t recommend using 3rd party power supplies with Nucleus since we’ve seen a few that have damaged Nucleus, even with “high end” PSUs.

Have you tried a different, standard USB cable yet as Rugby mention? I can’t say for sure if it is related but would be a useful test. Also, how is the drive formatted? Is it using NTFS/FAT32/exFAT/ect?

– Noris

@noris the Wireworld USB cable seems to be working now for the 3rd day in a row. So perhaps it was just a temporary initial hitch due to something else that I didn’t realize. I do have an ordinary USB cable to try if the problem crops up again.

Thanks for the heads-up about the power supply for the Nucleus.

It seems that all my drives are formatted as Mac Extended Journaled. Does that mean I have to reformat them?

Thanks again

Hi @Hasan_Latif,

Glad to hear that the USB cable is still operational after a few days!

OSX Journaled drives do have a limitation with a Nucleus, specifically you will only be able to read content from the drive, and you will not be able to save new content to the drive via the Nucleus nor make any changes on that drive via the Nucleus (as mentioned in our documentation here).

You don’t need to re-format it if it is currently working as expected, but you should be aware of this limitation if you wish for the drive to remain on OSX Journaled.

Since it appears that issues listed in this thread have been resolved, would it be ok with you if I go ahead and mark this thread a [solved]?

– Noris

@noris Thank you and @Rugby for all your help. Yes please close it.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.