USB output from Matrix Mini

I cannot get a connection between MacMini and Matrix Mini-i-Pro 3. The manual states that a driver for mac Os is already present, but I cannot replicate the connection illustrated in the manual. Instead, I get only Air play. So how does one implement the setting as shown (screenshot)

Switch the input to USB, then connect the USB cable.

If that does not work, try a different cable to a different USB port.

Input is greyed out.

I meant input in the DAC.

For Mac, it’s output. It looks like it’s already detected by the Mac.

Input to the Matrix Mini will not give me USB Connection

you should be seeing the device in the Roon settings under Audio

Unfortunately not

I do see the same address as Matrix (enabled and playing) and mini i pro 3 being ready to be enabled via airplay.
What’s up with that?

Well the issue is that I don’t want output via Airplay, but wired by USB .

Currently, you’ve got it connected via ethernet, right?
What’s wrong with that, or do you just want to compare to USB?
Did you check the Matrix’ own set-up menu to switch its input to USB, as @wklie suggested?

Tried both, USB C to C (failure) and USB C to A (connected to Mini-i), but whereas USB was shown in the display (with the correct sample rate) it immediately switched to Network streaming when the track was started. And yes, I want USB because it sounds better that way (on my other USB device).

Maybe first unplug Matrix’ Ethernet cable for a test, or go to “Roon” “Audio” click the cog wheel and “Disable” Matrix going through network, then set it up for USB and see if that gets you forward…
You need to see and “enable” it in Roon with it’s USB connected at some point.

1 Like

I very recently bought the matrix mini myself and have it connected both by ethernet and usb to a pc running linux. In my Roon setup I am presented with 2 Matrix audio devices that can be enabled as audio devices (one usb and one via ethernet). If I have the usb input selected on the Matrix, but send ouput via ethernet, the Matrix will automatically switch to ethernet streaming. Are you sure you have the intended usb device/zone selected in Roon?


Patrick how are you getting on with it, is it a happy purchase?

I didn’t realize that it could do auto switching, I might have to check out the options. I have a Chromecast audio connected but I have to manually switch to this on the occasions I want to use that. I generally leave it on streaming mode at the moment.

1 Like

It is indeed a happy purchase. Got in a set of Audeze LCD-X cans to go with it and I am happy. The auto switching you inquired about appears to be limited and could be a real nuisance depending on your usage. It seems that a stream initiated over ethernet will override the usb source that is already playing. Additionally if you are streaming to it over ethernet then it no longer appears as available output on the PC, so the switching is one-way.

1 Like

Nice cans as well so that should make a great combination.

Thanks for confirming the switching as that seems to be what I see. It’s not hard to press the remote buttons (yes always takes me a couple of goes to find the right button).

I have seen the same issues with the Zen Stream as well when trying to switch between Tidal connect, Spotify and Roon, so I imagine it might be a common problem with changing active selection

1 Like

Thank you Marin, great help. Your suggestions helped to solve the problem. Here are the steps I have taken:

  1. Disconnect Matrix from Network
  2. Attach USB C to A Cable.
    USB ![N0_2.PNG|690x479]
    Matrix now shows up in Audio settings.
  3. Stream Audio fromUSB - it works!
  4. Reconnect with network

    I have tried both settings,streaming from USB and from network. No problems switching back and forth.
    Problem solved!
1 Like