USB port not recognized in Vivaldi or Roon

I have been having problems with my Nucleus Plus losing connection with Roon. Dylan from Roon has been trying to figure out what is wrong. He suggested a test where I bypass the DCS bridge and use another connection with the Vivaldi DAC. I choose to connect the USB port directly to the Nucleus Plus. I set up Roon and the connection was working but there was no MQA. Then the Nucleus Plus started stutter and Roon started to go from song to song like a slot machine. I shut down the Nucleus Plus rebooted. Both Roon lost its ability to see the USB connection and now the Vivaldi only sees my Aurender connection to AES input 1& 2 and the Bridge Connection inputs 3&4. When I change the the input selector in the Vivaldi it does not see USB or coaxial inputs at all. I shut down the bridge but it does not cause the Vivaldi to see anything but the AES connections.
I suspect that The Nucleus PLus does not like the DCS Bridge but I could be wrong.
Any suggestions?

I just solved the problem of lack of recognition by shutting down the ViValdi completely by the use of the Power rocker switch in the rear of the unit and waiting till it recycled. I was wondering if you have any suggestions about the lack of reliable connectivity between the Roon Nucleus Plus with my network. I am using an Apple Extreme Router. You previously solved the problem of the lack of connectivity between the Vivaldi and the DCS Bridge.
Thanking you for all your help.

The Vivaldi doesn’t have any MQA support (yet) so I wouldn’t expect there to be any sort of MQA indication on it.

The Vivaldi will only allow you to switch to inputs where it sees a signal. In this case it sounds like something went haywire and the USB receiver crashed. I’ve rarely seen this happen so I can’t offer an explanation as to why it was happening. Power-cycling the DAC from the rear panel was the correct course of action here.

I’ve had no end of trouble with the Apple routers as they tend to do stupid things with some of the network traffic that Roon uses for discovery. We officially recommend against using the Apple AirPort products with our products for that very reason. I’ve had good luck with the Netgear R7000 (AC1900) and this is what I normally recommend for a typical all-in-one router/switch/access point.

The Vivaldi just repeated itself. It lost its connection to USB connection Roon. Interestingly Roon continues to play in the USB mode.

Any suggestion to a Router without a modem. I am using a Motorola Modem which works well.

The Netgear suggested is a Router/Switch/Wifi Access Point. It is not a modem. The cable modem would plug into the Netgear using the Network port on the back of the Netgear.

I think you asking for a Router/Switch without the WiFi capability? If so, just get the Netgear suggested and disable the WiFi on it.

What are the firmware versions installed on your Vivaldi?

From the front panel go into the menu and select INFORMATION then VERSION.

Thanks Daniel for your suggestion, I am actually looking for a Router WIFI without the modem. I found a number of Netgear models which fit the bill… I will try one of them and report back.

Control Board version 2.02. Front Panel: 2.02

The Netgear R7000 is functionally similar to your Apple router and doesn’t include a modem. I’m not sure which model you’re looking at, but this is the one I’m talking about:

I’m recommending this specific model for a reason. Other Netgear products are not as appropriate in this application and I’ve had numerous issues with some of them.

1 Like


Hmmm… although I don’t have a Nucleus+ connected via USB, I typically have a linux-based Roon endpoint connected and it’s used in long playback sessions without an issue.

You’re running the right versions so I’ll have you try one more thing on the Vivaldi. Beyond that I’d say that something is goofy in how the Nucleus+ is communicating via USB.

Try resetting the USB interface on the Vivadi DAC:

  1. Go into the setup menu and select Unit Settings
  2. Scroll over to the USB class (should be in the center of the first screen).
  3. Press the menu button to change it to class 1.
  4. Once that’s done repeat the process and switch it back to class 2.

This forces a reload of the firmware onto the USB receiver.

If this doesn’t work then there’s something that @dylan can try on the RoonServer side which might solve the problem. If that’s the case then I’ll PM him with the details.

Will try and report back. Thanks again.

Unfortunately, Andrew this suggestion didn’t solve the problem. The minute the music stopped playing the USB connection went into Mute and no input both in red. The Roon application started scrolling widely from random song to random song uncontrollably. The Nucleus Plus has been terribly unstable from the beginning.I could understand why the Apple extreme is responsible for the poor network connectivity but not the screwy USB problems. Please forward on to Dylan.If you can tell me how to send a video from my iphone, I can document the wild scrolling on the Roon application.

I don’t have dCS gear anymore, but I had a ‘rapid scrolling through songs’ on a few albums after pressing Play yesterday. That was with my laptop connected with USB to my DAC.

Once I I turned off my DAC, restarted Roon, then turned the DAC on again it worked fine. Different situation, but some similar behaviour from Roon.

Thank you Gregory. That also works but this situation seems to be chronic.

I sent a note to @dylan with an idea worth trying from the Roon side. He should be back in touch with you.

For whatever it’s worth: My setup has an Airport Extreme as the firewall/router to the internet, followed by a Netgear GS116 switch. My setup is connected to the switch as are all other components. I don’t have issues with this setup.

Thanks Miguel. I too have a similar setup with a Cisco top of the line switch. I had no problems running the Core from my HP desktop. Everything started to go downhill when I switched to the Nucleus Plus as my Roon Core.
Lack of connectivity and now the USB issue, I am convinced that this is a hardware and or or software problem with the Nucleus Plus but I will be switching to he Netgear Router suggested by Andrew and will report back to the Roon community. Thanks again for your input,

Which Cisco switch do you have?