USBridge Signature + Digione Signature + Shanti + Wifi + RoPieee + Focal Arche Functioning

Greetings. First post. I wanted to describe my experience with the stack in the title. I’m very much a neophyte here in many respects. Sorry if it’s a bit rambling, but such is my nature. Early this year I decided to try and get a high quality headphone setup going. I started doing some research and learned about CanJam, so we made it a weekend trip to NYC in February. Despite the travel ban causing some disruption for Chinese vendors, I thought it was a great show and experience trying a ton of products. This was the first time I’d ever seen Roon. I was highly impressed. That so many vendors were using Roon is quite an endorsement to me. So I added that to the list of things to investigate.

Fast forward a few weeks. I have a Focal Arche, Focal Stellia, and the Allo stack of a USBridge Signature with DigiOne Signature HAT (to give me flexibility on outputs), their Shanti power supply, and the Comfast wifi adapter. It took a while to receive (I’m in the US), but considering the state of the world, not too bad. I’d been using my Macbook as a source with the Arche via USB for a few weeks and it was good and improving with listening time. It was time to start tinkering once the USBridge arrived.

And boy has it been a lot of tinkering. That’s why I say “functioning” in the title. I’m still not quite where I want to be, but I have something working that sound very nice. I’d ordered the Allo bits with their pre-installed DietPi+Allo MMC and screwed up the setup right off the bat. On first boot (with wired ethernet) it asked if I wanted to let it update to 6.28 from 6.26. Sure. Oops. I have a few microSD cards, so I spent a lot of time trying various distributions (Volumio, DietPi, Moode) with various updates and driver combos. Nothing worked getting the Arche playing via USB. Eventually I gave coax a try via the Digione Signature and that worked straight away with all the distros. It sounds great, even just AirPlay’d lossy sources, but the coax input “only” goes up to 24-bit 192khz PCM where as the Arch supports higher resolution via the USB (despite me not having any files in such formats).

Anyway, once I could get audio out I started looking at getting setup with Roon and Tidal. I signed up for Tidal their spring promo of $4 for 4 months (nice enticing pricing to try, particularly with shelter-in-place orders). Using the Tidal app on my iPhone I was able to output over USB (with USB adapter of course) to the Arche and play hi-res with no effort. It’s great and gave me a reference as to how some familiar tracks sound playing through that path. I signed up for the Roon trial, installed Roon on my Macbook, authorized my Tidal account to Roon, and I was able to play via my Macbook as well. And then I streamed via the DigiOne and that worked great. In some ways better than directly on the Macbook. I could trigger pops and crackles when playing over USB to the Arche by simply scrolling in some web pages, but not via Roon.

As I was doing this I ordered a Dragonfly Cobalt to give that a try with the Stellias and using my iPhone as a source. And it came with a code for a 60 day trial of Roon, but I’d just signed up for the 14 day trial a few days before that arrived. Oh well. I’m likely keeping Roon anyway. I didn’t like the Cobalt sound at first, but it’s improving with use.

The next step was getting Roon off the Macbook. I’d been reading on these forums about ROCK and MOCK. I’m a long time Unix admin, not so much Linux, but I get around on Linux as long as I have a search engine handy. I have an idle server in my rack, but it was for all intents and purposes completely segregated from the rest of my network and long story short it took me a week before I had my network reconfigured to get it where I could setup Roon in an Ubuntu VM that was reachable by my Allo (with DietPi by this point).

Once that was working I thought it time to tackle wifi again. I had played with it a touch during all the above, but no success. I dug in and found that getting the Comfast adapter configured on Volumio, Moode, and DietPi would lock up the system. Some would crash at trying configuration. Others would configure and upon reboot crash. By crash I mean some sort of kernel panic with a stack track emitted and the keyboard stop working. I checked drivers both from Allo’s site and looking wider into drivers out there for the chipset, but no success. That is until I tried RoPiee. I’m in experimentation mode and honestly I didn’t care about AirPlay or anything else. I did all this to try it via Roon, so I thought I’d give RoPiee a try and wow is it really simple.

Because of my USB to Arche troubles, with all the other distros I setup Ropieee with the DigiOne signature straight away. Bog simple setup and it worked immediately. Honestly it felt a bit odd not having to get on the console to do something. It just worked. After a few days I decided to see about wifi again. I really do want wifi to work so I have more flexibility in placement. To my shock, in Ropiee it “just worked”. I plugged in the adapter, configured it on the network tab in the web-ui and it needed a restart. I assumed it wouldn’t come up. But it did. And it worked. No drama at all (aside from the suspense). I’ve now got several hours of listening through it over wifi and it’s been perfect. Not cutouts, or pops, or anything. My wifi network is quite busy with the family stuck at home. My network monitor shows I streamed around 13GB to this over wifi just yesterday and it was as solid as it was when wired. This while lots of other network activity is going on. Big thumbs up.

So with that success, last night I tried to see if I could reconfigure RoPiee to stream to the Arche over USB instead of Coax. Failed again. Similar kernel messages to the other distros. I’ll say I think DietPi got the closest as it provided the most info showing some interpretation of the hardware capabilities, but still didn’t work.

I’ll add that the specs on the Arche don’t list Linux compatibility. It doesn’t need a driver install for Mac, so I expected it was USB audio compatible. I did reach out to (what I guess was US) support and they said this was over their head and gave me a link to a French site.

I’m mostly happy. Obviously I’m still work-in-progress here. I didn’t expect I’d need to tinker this much, but at least this is up my alley. Hopefully USB streaming will work eventually. I need to either move my CD rips in iTunes (I specified ALAC when ripping) over or just re-rip everything entirely. Tidal is excellent. I’ll very likely continue with that subscription after the promo is over. I wonder how well my Roon VM will fare with more content. I gave it 4 cores and 8GB of memory per the recommendations (the server has 128GB of RAM, 12 cores, and nothing else running). I don’t mind switching to ROCK on a NUC with super fast drive if I have to. It’s just I have this server idle otherwise anyway. And of course I’m eyeing upgrades. I auditioned the Stellias with a Benchmark HPA4 and one of their DACs at CanJam. Very very nice. Not this year’s budget, for sure.

News Flash: Focal released a firmware update.
Please follow the instructions via this link:

Focal released an update for your DAC.

Many thanks for the notice. I don’t have any Windows machines to do the update, so I attempted to do it with a Windows virtual machine. I was able to get the Arche working via USB passthrough to the VM, but the firmware update was not successful. I had to take it to a local computer shop. It updated there hooked up to a real Windows 10 machine. I reconfigured RoPieee to USB audio, connected via USB and enabled it in Roon – and it worked right away. I still seem to be limited to 192kHz, but I was able to play some DSD64 files without conversion (which is a step forward from Digione Signature output). I need to play with this hooked up to my Mac too to see how that’s changed. Previously I could set the output to 24 bits 384kHz, which is as described in the manual. Playing DSDs would cause problems, though. I look forward to exploring this further and comparing sound quality relative to the Digione Signature board I’ve been used to after all this time.

Looks like the update removes 384kHz sampling rate with UAC, not that UAC worked well before. I’ve plugged the Arche into my Mac and it only allows me to select out to 192kHz now (24 bit).

I’ve run into a few problems. Not sure if I should create a new thread or not. I’ll start here, because it’s this very same setup.

  1. My wifi adapter quit working. Not a huge deal, as I currently have the setup reachable by ethernet cable, so I’ve just switched to that. I had considered moving this to a nightstand where ethernet will be difficult to get to with a decent wife-acceptance-factor. Not the focus of my concern, but thought I’d note it, because RoPieee was the only distro I could get that wifi adapter to work on before (and with little effort at that).

  2. After getting USB working, I’ve been doing A/B testing between USB and SPDIF (via the HAT). It’s rather cool that I can have both inputs configured and attached to the Arche and have Roon stream to both as a group allowing me to switch inputs on the Arche hearing the same things. I’ve found since hooking up the USB that at times just break. It’s random. I thought maybe my network was having problems, but I think I’ve eliminated that. This is all wired, no wireless due to the item above, and it just stops or chops and sometimes to the point Roon loses the RoPieee device. Finally, it’s happening enough I’m asking for help. I sent feedback addbb5b9e8d4f858 to see if @spockfish can see anything.

  3. This may be related to item 2, but I can’t seem to leave the RoPiee on. If I listen and come back the next day, it requires a restart. The web UI is unaccessible and Roon likely doesn’t see it. That means a hard power-off and I fear I may have corrupted a filesystem along the way. I’m trying to remember to issue the shutdown command in the web UI when done with a session so I can power it off safely and make for a safer shutdown.

Hi @madtrader,

  1. I see dropouts in the RAAT log. This usualy points to an issue in the infrastructure. How often is your Roon server restarted?

  2. I see a bug that causes the webinterface to crash every once in a while (resulting in not being able to reach the UI). The crash points to issues in the networking infrastructure as well.

There might be a chance that 2 is being triggered by 3. So the memory leak results in ‘memory pressure’ that in it’s turn results in all kinds of ‘weird’ issues.

I’m going to have a look at the bug in 2, but that’s certainly not a quick fix. Can you, for now, stay on wired and change to the beta channel? That makes it easier to try it out, but on top of that there are already a few updates that might solve this issue as well.

Switching to beta is done from the ‘advanced’ tab in the webui.


Hi @spockfish,

Thank you for investigating.

You point to infrastructure and something happened since I posted. The managed switch this is plugged into died. Or something. I also have my work notebook plugged in and when I started work yesterday networking was broken. I was able to determine this switch was in a bad state and nothing would revive it to actually route traffic or be controllable from the control system. I even did a hard reset and it wasn’t recognized by the control software to setup again. So I pulled it out, switched some more things to my wifi network and configured the upstream managed switch to put this on the correct network. I was able to listen fine for a short while yesterday.

I’m hopeful that was it, but I suspect not entirely. I forgot to shutdown again and today it was unreachable again so I hard powered it off waited a couple minutes and powered it on again. I saw your message here, so when it was back up again I switched it to the beta channel and had it do the update. I had it playing music again while I started to type this reply and it has again had some issue. It was mid track and then hung and skipped tracks to the end. I went to the web UI to see if I could do another “send feedback” press and the UI hung. After a minute or so the web UI came back again, so I just did one of those, identifier 97cd552809576b25 .

Oh and the last restart of Roon was about the last time a new version came out. Was that a week ago? It’s an Ubuntu virtual machine on a FreeBSD host and they stay up all the time with restarts pretty much only for patching. I’ve got nothing else going there right now, so no other processes or VMs sucking up resources. It’s very idle.



The issue with the webinterface is something I need to look in more.

The RAAT log shows again a lot of ‘noise’ indicating there’s something wrong with the network infrastructure. So I would seriously suggest to restart your Roon server. If the problem persists you could contact the Roon team, maybe they can share more insight into what’s actually happening in/on the network.

Regards Harry

Thank you again, @spockfish . I’ve rebooted my Roon server (and applied some updates while at it). I’m not sure if it helped or not. When I got all connected again things played fine, but then had more dropping issues and the endpoint disappeared from Roon again. I was able to play more music before it got bad, but still happened. Also, had to hard power down the Allo box again as it became unreachable from a web UI perspective when I first took a look at it today. I see another update is available and I’m applying it now.