Use Zotac CI331 as Roon Bridge (Linux fails to support HDMI audio out)

Hello everyone,

I’m trying to use a Zotac CI331 as Roon Bridge endpoint. When using Windows 10/11 this works without any problem, but I don’t like the big footprint of Windows for a mini PC with one specific task: Roon Bridge. However, when I try to use Linux the HDMI Audio output is not available, the one output that I need for multichannel audio support. The Zotac CI331 uses the Intel High Definition Audio specification (Digital 8 Channel Audio Lossless Bitstream via HDMI), so I assume Linux should be able to use the HDMI Audio output. So far I tried ROCK, Ubuntu and DietPi. All fail to support HDMI Audio.
Is there someone here who can point me in the right direction? Thanks!

Cheers,
Dennis.

It should work with ROCK. The new 2.0 should support it. If it doesn’t I wouldn’t know where to start.

Then you’re in the same boat as me. ROCK installs without problems, but no HDMI audio out. :cry:

On the Audio tab in settings do you see a list like this

If you connect your devices HDMI to your TV do you get the text appearing top left?

I did have a really cheap style NUC (not a NUC) and it didn’t either. It may be device dependant.i

@BlackJack
I think you nailed it. The “core” audio, analog only, is available. I was looking for a cheap Roon bridge with hdmi/multichannel support. This is possible with Windows 10/Windows 11. I hoped for ROCK. But as long there’s no Linux support for the converter chip all I can do is hope, I’m afraid.
It looks like that the previous CI331 model, without the new BIOS with UEFI and hdmi 2.0 support, did all I wanted.

Just to be clear, you have tried ROCK 2.0? Only out in the last couple of weeks?

Hi @Henry_McLeod,

I tried ROCK 1.0 build 253/254, I haven’t seen a new ROCK 2.0 build just yet.

If you go to settings and the About tab, you see the version the ROCK is on

Here it shows which ROON version is running, not which ROCK version that is installed, to my understanding.

I would prefer my ROONBRIDGE running ROCK instead of Windows.

See the following thread:
What’s coming in Roon OS 2.0 (not Roon 2.0, but Roon OS 2.0)?

I get ya.

ROCK installs and then updates when selected when you connect the Roon Remote app on 2.0

OK. It looks like I mistook the latest build for 2.0. It has fixed HDMI for some without Intel HD Audio but that is on NUCs.