Using a Mac USB-C hard disk with Nucleus

Just received my new Nucleus+.

I am attempting to use an external 4TB HDD with my Roon database backup and music files. This disk was used previously on my MacBook Pro; the HDD has a Thunderbolt 2 interface and was connected to the Mac via a USB-C port, with the Apple Thunderbolt 2 to USB-C adapter. I am using the same USB-C adapter to connect it to Nucleus+. The Disk Utility on a Mac shows the filesystem as “RAID Volume Max OS Extended (Journaled).”

While I can login into Nucleus+ from an iPad, Roon on Nucleus+ does not appear to see the hard disk. It does not seem I should be adding it via the “+ Add Network Share” option, as it is not a network disk? Perhaps the disk filesystem is not compatible with Linux?

What should I do?

I am getting an internal SSD in about 2 weeks, so this problem shall go away, but it’d be good to know a solution anyway.

Also, how do I access Nucleus storage (either an external or internal disk) from a Mac computer on the same network?

Thank you, Andrej

I didn’t think Rock supported thunderbolt connections, have you tried using a usbC to usbA cable to connect the disk to the Nucleus+

See Thunderbolt 3/2 drive support on ROCK

well, i am using a Thunderbolt 2 to USB-C Apple’s adapter to connect to Nucleus+ USB-C port.

i also tried two other Mac disks: one SSD via USB-C without an adapter, and a USB-A HDD. none of them are recognized, though I may not have turned the Nucleus+ off and on after connecting the disks (not sure if that is needed).

I’m not sure if rock supports HPFS drives…I’ll have a try later maybe too with a sacrificial external disk.

The thunderbolt port is not active. Intel has not gotten their act together yet on thunderbolt and Linux. When they do, it’ll work. In the meanwhile, use USB3.

thank you! good to know :slight_smile:

what Mac filesystems are compatible with Nucleus? i only have a Mac to format my external disks.

what version of Linux is Nucleus+ running?

how do I access my Nucleus disks from a Mac on the same network? smb?

can I login into Nucleus?

is there a manual for the Nucleus OS?

thanks, andrej

I use exfat, to connect from a Mac use finder then connect to server using smb and you will see the disk from there, I have the Rock data folder mounted at boot on my Mac.

yes, but only read-only. you can however format ExFAT with MacOS.

The kernel changes from update to update, but the distribution is fully custom. We will be releasing a whitepaper explaining all this shortly.

From a mac: cifs://Nucleus/Data and then look at the Storage folder – you will find your USB and internal storage there – one folder for each.

no. There is a web ui you can get to from sidebar -> settings -> setup -> configure roon os devices

very helpful - thank you!

i am restoring the backup now just fine …


good news - up and running!

the Mac Journaled HFSP+ USB-A external HDD was not shown by Roon in its Storage folder, but I am now reformatting the HDD into exFAT, so hopefully this will do the trick. in the meantime, i use music storage on a disk connected to a Mac on the same network, accessing it via smb.

thanks, andrej

The exFAT HDD connected via USB-A is visible in Storage and works, but I can’t write on it from a Mac that displays the Storage folder via smb. Even though clicking cmd-I on the disk name on a Mac says that I have Read & Write privilege, there is a “red stop” sign on the folder icon and I can’t open it. How do I get r/w permission for it, so I can put new music on this Nucleus+ disk from a Mac?

Hopefully this issue does not occur with an internal SSD (which I will install as soon as I get it in about 2 weeks), or the same solution will apply? How do I format the internal SSD, so that it is accessible (read and write) from a Mac?

Thank you, Andrej

Hi Andrej,

Check this out. It might relate to your issue.

Cheers, Greg

You do need to add the external USB drive as a network share/folder, using Greg’s linked instructions above.

When you add internal storage later, Roon will see this storage under the default “Music Folder” so you won’t need to add it as a networked folder.

Roon OS can read and write HFS, but read only for HFS+

Hope this helps.

great - using cifs did the trick, as described in the link you cited - many thanks, andrej

1 Like

i spoke too soon: while i can now go into the USB disk folders on a Mac, i can’t create a folder or a file in them; and Roon’s Backup into it does not work either. the fs of the HDD is exFAT. this is a hassle, as I intended to use a Mac to update music files on the Nucleus.

Have a read of Vova’s post (40 onwards) of this thread.

You can use a HPFS drive externally on the ROCK but you will need to copy files to it while its connected to a MAC… then eject it and connect to the ROCK/Nucleus and it should see all the files

right, i am sure this would work, but it is extremely inconvenient and i hope the remote mount issue will be resolved soon, presumably via an OS update.

thank you for the suggestion, but unfortunately it didn’t help.

smbutil shows:

smbutil statshares -a



and i still cannot create a folder on the external USB disk. i can “touch” a file, but cannot mkdir a folder.

i will check next how the disk is formatted, and if it is HFS+, i may try to reformat into HSF, per Sean2016.

my external USB disk is exFAT.

there is a potentially related problem, and certainly a problem indicating an issue with Nucleus I/O to external USB disks, so i am mentioning it in this thread:

Roon does not see all my tracks anymore. It is missing about 15,000 out of 55,000 tracks. The files are there (I checked by mounting the disk on a Mac, I even synced it again with my master music storage on a Mac): Forcing a re-scan of imported files function in Settings scans the right number of files, but the number of imported tracks is incomplete, missing about 15,000 tracks. Interestingly, cleaning the Roon library (in Settings) shows about 15,000 tracks were removed. So it seems Roon imports them, but then soon decides they are not there, and removes them. Maybe it is a slow disk …

I am waiting on an internal SSD delivery, hoping these problems will go away, but I thought the developers would like to know anyway …

Thanks, Andrej