Using Linn Majik DSM

I can access the linn through airplay but cannot via the network. Sometimes it comes up as a network item in Audio/settings but will not save

Hello @Charles_Rossiter,

Thanks for contacting support, I have a few question as to better understand the issue here:

  • What is your Linn Subnet configured to in Roon Settings?
  • How is your Linn Majik connected to the network? Are you making use of any Powerline adapters/range extenders?
  • What is your router model/manufacturer?
  • Have you tried rebooting your Core, networking gear and Linn DAC yet to verify if there is a change afterwards?


Subnet for Linn Streaming
Network cable used to connect to Linn
Router Netgear CG3000-251AUS
Rebootong does sometimes work but only for a short time.

Regards Charles

Thanks for letting me know @Charles_Rossiter. Can I please ask you to try a different Ethernet cable for your Linn -> Router connection to see if that helps?


Tried a different cable.

Now i have found that if i run linn config, reboot the linn DSM from there, then the netweork linn comes up in roon. AND it can music can be played, etc… BUT ater a minute or so the linn drops out. Then to get it back I need to reboot the linn again. Any further suggestions?

I am also asking Linn similar questions

Charles Rossiter

Hello @Charles_Rossiter,

Thanks for letting me know that info. I’m wondering if the router has anything to do with this issue and is blocking multicast packets. Can you please check to make sure multicast is enabled in the router config settings?

We have also seen “Disable IGMP Proxying” help in similar situations, if you have that setting on your router I would give it a go as mentioned in our Networking Best Practices Guide.

Other than my above suggestions, I would double check that any firewalls are configured to properly allow Roon to operate, for Windows you can use this Guide and for OSX you can use this Guide.

Please let me know if those suggestions help.


Thanks Noris. I have a work around. When I want ot use roon i can reboot the modem/router and it seem to work well.

Another question.
I am running room on my computer, but i want to try it on my NAS drive. Can both systems run, not simultaneously, but independently, by just connecting the core on say my computer and then running the core on he NAS. Then can i just just tell roon on either the NAS or the computer which core i want to use after disconnecting the other. I am thisnking that both would be independent. If then the NAS with core does not work then i can revert to roon core on the computer. Also can the roon on the computer act as a remote for the NAS when the core is run on the NAS.


Hello @Charles_Rossiter,

That workaround you posted does not seem like one that you should have to do to get the Linn to show up. I believe there is something else here at play blocking the Linn discovery and getting the Linn to show up without having to reboot it every time is going to prevent issues in the future. Are you absolutely sure there is no firewall blocking the connection to the Linn?

As for your question regarding the NAS, I’m not sure that I follow. If your NAS is a QNAP or Synology NAS then you can install Roon on it but if you would like to just use it as a Network Storage Location you would need to add it to Roon using these instructions. Provided that your NAS meets the minimum requirements then yes, you would be able to use your computer as a remote and have your Roon Core on the NAS.

You are limited to just one Roon core per license so if you would like to switch between the NAS Core and your PC Core, you will be prompted to unauthorize the other Core in a page similar to this one:

I would, however, suggest leaving your Roon Core on your PC unless your NAS is more powerful than the PC but I have often seen that is typically not the case for a majority of NAS’s.


Thanks Noris I agree that I should not have to reboot router/modem but cannot find a setting in the router setup that looks like it wil stop it. The other interesting thing is that I don’t seem to have problems with other things on network. (Tv’s, blue ray, Optus box, computers). Perhaps the usage is totally different. I can work with rebooting but it is inconvenient. I will keep trying things and let you know if I can find an answer.

But the authorisation of systems is exactly what I wanted to know. I now can use either system and check out which works best. Then I can decide whether I would prefer to go to the Nuc solution.

Thanks for your help Noris


1 Like

Hello @Charles_Rossiter,

We discussed this issue with the technical team, our conclusion is that something is occurring with the multicast routing on your router that is causing the Linn to get “lost” on the network. Roon uses multicast packets to discover devices on the network, this is what allows it to work across many different networks with many different types of devices.

We would recommend trying a new router in your setup to see if this resolves the issue for you. You should check with your ISP on how to set up your modem correctly to ensure that all services remain functioning, including things like VoIP and IPTV service.


RThanks John My ISP provider and systems will soon be changing. Currently my router is a Netgear CG3000v2, Firmware Version
V2.08.07 which was supplied by my ISP provider Optus. This runs on a cable to the Optus network here in Melbourne, Australia. We are about to have the network system upgraded to the NBN (National Broadband Network) And presumably this will require a new router/modem. This will be a big change and i am loathe to change modems at this time.When this happens i think I will need some I think I will proceed at the moment with my work around and when the