Using QNAP Roon to drive USB DAC in another room?

My Roon running on a QNAP server with USB output does a GREAT job of driving my Chord Hugo via USB.

I want to run my Sennheiser HDVD 800 DAC that is on another floor with Roon by some means. I want to provide sufficient bandwidth to drive the DAC at high resolution audio rates (that suggests that bluetooth and WiFi are out, unless I am told otherwise).

Is there a way to get a wireless version of USB? Do I have to run a USB wire with repeaters to accommodate the longer distance than the 3m that USB supports at full data rate?

Or is there some sort of Roon add-on (or another system) onto which I can put my music, get the great wireless remote control that Roon provides, and have that great user interface?

Thanks!

Maybe I’m not understanding, but why are you not using ethernet from your router to your Sennheiser DAC or to a Roon bridge device then USB from the Roon bridge to Sennheiser? If you have a good WIFI signal, you could use WIFI instead of ethernet to a Roon bridge such as a Raspberry Pi 4.

Thanks for your response, Jim_F.

I don’t know how, if I ran an ethernet from my router to my Sennheiser DAC, I would get the signal into the DAC… it has USB and coax input, not ethernet.

I am intrigued by the Roon bridge device. I will have to learn what that is… it may be what I need.

You can assemble a Raspberry Pi4 with parts from Amazon for around $74. It takes about 15 minutes to assemble, download the free RoPieee software, and flash to a micro SD card.

Thanks again!

How does the signal get out of my QNAP server to the ropiee? I take it that the Ropiee sits near the Sennheiser DAC, and the Roon system is on a different floor. It looks like it does not take internet but takes USB (wired, I assume), and I saw what appeared to be a wireless USB plugin in the info.

Once installed, does the Ropiee give the same powerful user interface that I get with my iPad or iPhone running the Roon Remote app?

Thanks again!

I assume your QNAP is connected to your router by ethernet. The RPi4 running RoPieee would also be connected to your router using ethernet. If not ethernet, it can connect by WIFI. The RPi4 has WIFI built in. The RPi4 would sit next to your Sennheiser DAC with a USB cable from the RPi4 to your DAC. I have two of these connected to headphone DAC’s and they work very well.

Your music travels from your QNAP back to your router by ethernet, then from the router to the RPi4 by ethernet or WIF, then USB to your DAC. You will still use your current Roon control devices. This is just another Roon end-point, not a Roon control device. You can add a screen to the RPi4, but that is not needed and just another complication.

1 Like

Yes indeed, my QNAP connects to my router via Ethernet.

If my RPi4 would connect to my router via Ethernet and sit next to my Sennheiser, I need to run Ethernet up to the floor where the Sennheiser is.

Would it be simpler to run a USB cable from one of the ports of my QNAP to my Sennheiser, just as I did to my Chord Hugo that sits next to the QNAP, if I can accommodate the length of the USB (e.g., via repeater, or maybe it is close enough)? Then I just plug the USB cable into the DAC USB input… no extra box needed (and I can still use the WiFi control of the Roon on the QNAP as I do for other wireless endpoints in the home, but get the higher data rate of a wired connection and use the quality of the Sennheiser DAC and headphone.)

That is another way to do it. I don’t know the pros and cons of one way versus the other. Pulling an ethernet cable is pretty simple. I guess you just need to decide which makes more sense in your situation. Control of your device in Roon will be the same regardless.

Thanks so much… your help is much appreciated!

1 Like

If you decide to do a RPi4, this is what I used:

https://www.amazon.com/gp/product/B07TD42S27/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

https://www.amazon.com/gp/product/B07TYQRXTK/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

https://www.amazon.com/gp/product/B07WG4DW52/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

I purchased the raspberry pi 4 type b board, case, and power supply you suggested, downloaded ropiee to my WIndows 10 machine and copied it (via file copy, not the Etcher or Rufus mentioned) to a 16 GB microSD, put it into the slot, attached Ethernet going to my router, then attached power.

Red light came on and green light continues to blink about 4 times in a one sec interval and stays off for about 3 sec, then repeats.

I have no idea how to go further. I have no display on it, and it seems that the connectors that look like micro USB connectors on the board are not (too small - afraid to really push).

I don’t see a new address on my ethernet with vs. without the Raspberry Pi plugged in, I don’t see a new WiFi address I recognize, and I don’t know what to do next.

Maybe I will try again loading the SD card, but this time using Etcher rather than Windows file copy.

Any advice?

Thanks!

(P.S. I even made my first latte in my life, since the Ropiee Beginners Guide mentioned to do that while it was setting itself up!)

Hi John, that won’t work. You must burn RoPieee to the SD card using Etcher or Rufus. And when you put the card then into your RPi and power it up for the first time, it must be connected to the network via Ethernet as you did. It then will configure the operating system and Roon Bridge. Once booted up (another Latte seems in store for you and it must be a Latte, not black coffee) you will be able to discover your new endpoint and USB DAC in Roon. Good luck!

Thanks, Andreas. I did all that… I used Rufus, made a proper imaged memory, stuck it in, and voila’ – I got the 1/2 Hz blinking that indicates proper ropiee operation.

But…

What do I do next? I go to Roon, go to “Configure Roon OX / Search for Devices,” and it just sits… does not even find devices already there.

Meantime, the green light on the raspberry pi blinks, as it should, once every 2 sec.

What I would do first is going to the RoPieee setup screen… Do you know the IP which was assigned to the RPi with RoPieee? Use it to load the RoPieee setup screen using a browser of a network-connected device: http://xxx.xxx.xxx.xxx or you can try to loas it with http://ropieee.local.

Make sure RoPieee is configured for ‘Audio USB’ and ‘No HAT configured’. Set up your time zone.

After that, with your USB DAC connected and switched on, you should find it on the Roon Setup --> Audio page. There you can enable and configure the new device and then try playing to that new zone…

I much appreciate your help!

I am using it without display or keyboard. How do I go to its display?

I am on Ethernet, but cannot locate its address.

Thanks.

John, you can use any laptop or PC or even tablet connected to your network. Just type in the browser http://ropieee.local… This will bring up the RoPieee configuration page and from there you can make sure it is set up for USB output.

You don’t need to connect display or keyboard to the Rpi…

Hey, thanks! Making progress. I got to its screen doing just as you said, and I set various setting for WiFi operation, then pushed “Configure.”

I have had a screen now for 30 min that says “Your device is being configured. Please be patient… this will take time. Don’t turn it off.”

How long? Does it stop on its own? Will I indeed be able to send it Roon music via WiFi that it outputs to my USB DAC via USB (just as I can do with my iPad as a Roon endpoint, or my laptop?).

Thanks again!

I don’t remember how long this took in my case, but give it some more time… If after an hour or so the screen sticks at the same point, I’d say reboot the RPi and when it is booted try to load the setup page again to see if your configuration has been saved.

If anything should go fatally wrong, you can anytime re-flash the SD card and start over. The first time I tried to set up my RPi with RoPieee this is what I had to do…

Yes, definitely, if the WiFi signal strength is sufficient. I use my RPi endpoint connected to WiFi. But I would recommend to set it up first connected to Ethernet, and if you have discovered the endpoint device in Roon and made sure that it is able to stream music to it, then it is time to try and change the RoPieee network configuration to WiFi.

FINALLY! It works as I had dreamed for! I really wanted the poorer of Roon at my top quality USB DAC AND what will become a great two channel system, controlled wirelessly by the great user interface of the iPad.

(And I learned to make latte in my Jura Capresso!)

Thanks to Raspberry Pi and your advice on this thread, it is now a reality.

Again, thank you!

2 Likes

New problem… my RPi endpoint no longer appears as a possible audio zone after the update to Roon 1.8. Is this a known bug, or do I need to reset something? The RPi DOES appear in audio settings with the other endpoints, but while the other endpoints are listed either in sections saying they are direct wired or that they are “Roon Tested,” these are just listed in a section of their own called Roon (not Roon Tested). Thank you for any advice!