Using Roon with non-Roon certified devices

Taking a new look at Roon. I have five devices that I would like to use with Roon, but are not on your compatibility list. Would like to know how to make them work with Roon:

— Focal Arche DAC… Actually, this is only a partial problem. It’s connected to my Mac desktop via USB and Roon sees it as one of the system audio options. The issue is that the Arche is also connected to a Autonomic Mirage MMS-1e streamer as an alternative source and Mirage is not Roon comparable.

— Per above, compatibility with my entire Mirage system, which includes a 3e as well as the 1e.

— Como Audio Musica player. Not Roon compatible, but does have bluetooth and wifi with DLNA capabilities.

— Sony Walkman NW-WM1Z and NW-ZX505. If there is a Roon app for Android, then the 505 is all set. But there is no wifi on the 1Z.

Roon Certified changed a while back. DACs may be Roon Tested, but this isn’t essential, and those that haven’t gone through the certification programme will still work. In your case, you don’t want to use System Output since this goes through the Mac system mixer. Instead, use CoreAudio and configure the DAC manually according to its capabilities.

For the other devices, if these are to work with Roon, they need to be Roon Ready since they are network streamers. However, the responsibility is on the manufacturer to make these work with Roon, i.e. build the Roon software into their firmware and work with Roon to achieve certification.

I’m not sure what Roon can do for you if your Walkman doesn’t have a network connection.

@support – I have figured out some of this, but problems/questions remain:

– In addition to my Arche, which is not Roon ready or tested, I also have in storage a Schitt Jotunheim 2, which isn’t on your tested list either although similar Schitt DACs are. I gather that with a USB connection, ready/tested status is irrelevant. But would there be any advantage to using the Schitt?

– My Mirage system shows up in Roon as AirPlay devices. The Autonomic Mirage MMS-1e player itself is one (The installer set it up as a stand-alone for headphones with its own music library that feeds the Arche via coax). The other four are speaker pairs/zones (MBR, LR, etc.) which connect to the Autonomic Mirage MMS-3e. All five have the same problem: Roon feeds the zone and I get one track to play. Then Roon keeps on playing, but the speakers or headphones go silent. What’s up with that? I thought Roon is fully compatible with AirPlay?

– And speaking of AirPlay, I simple cannot connect Roon to my Apple. TV. Again, connection seems to be made, but no sound comes out of the TV soundbar and no visual indication of Roon’s presence on the TV screen. Not a huge priority for me, but still would like to know if there’s a fix?

Please note, I am a community member and do not represent Roon. I’ve moved this thread to #support, so it gets more attention and will be picked up by support.

1 Like

thank you…

1 Like

Screenshots, if that helps!
Screen Shot 2021-03-20 at 3.18.47 PM|690x485

Hello @Al_Gordon,

As far as Roon is concerned it’s just another USB DAC. Whichever sounds better to you is the best choice.

We cannot guarantee that Roon will work with every AirPlay device. That said, we’ve tested dozens of them in-house as a part of the Roon Tested program. On top of that we have thousands of reports of other AirPlay devices working great with Roon.

I can’t recall any reports similar to what you’re describing so it’s difficult to pick a place to start troubleshooting. Do you have a Mac or an iPhone? If so, try playing Roon to the “System Output” zone of either device and then selecting the MMS-1e as your “Output” in the macOS sound settings or in the iOS Airplay Menu. This will bypass Roon’s AirPlay integration and use the native Mac/iOS pathway.

There’s an issue with enabling some AppleTV devices that we’ve been investigating. Could you try

A) Open settings on the AppleTV
B) Navigate to AirPlay and Homekit
C) Tap on “Allow Access”
D) Set “Allow Access” to “Anyone on the Same Network”
E) Set Require Password to “On” and create a password
D) Back out of the menu to the home screen
F) Try to enable the zone in Roon. It should ask you for the password



Hi John,

If so, try playing Roon to the “System Output” zone of either device and then selecting the MMS-1e as your “Output” in the macOS sound settings or in the iOS Airplay Menu. This will bypass Roon’s AirPlay integration and use the native Mac/iOS pathway.

That works, but the sound quality on the MMS-1e is inferior to Roon’s direct Airplay output. In fact, skipping AirPlay altogether. Simply connecting the Arche via USB to my Mac sounds better.

I keep trying various permutations without getting anywhere. One song and done through all the five Mirage zones. I wonder whether, notwithstanding Autonomic’s support for AirPlay, the Mirage’s proprietary streaming system doesn’t want to play nice with Roon’s?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.