Using Sonos ZP90 with ROCK

I have a similar issue and wondering if this has been resolved. I have one Sonos zp90 and Roon rock both direct to router. Can see the Sonos on my player but cannot seem to do anything with it, nor does the Sonos see roon. Surely I am missing a step ?


Does it show us like below? It’s a 90.

Hi @Julian_Higgins,

Does the Sonos zone show up in Roon Settings -> Audio? Have you enabled it prior to trying to start playback? Could you provide a screenshot of your Audio tab if it does not show up there?

Does show up with ip address. In device setup, the SAVE button is greyed out.

And can play to zone but shows ünable to connect to roon etc…

Both players , rock + zp90 direct to same router.

Hi @Julian_Higgins,

The save button would only be available if you actually make changes in Device Setup, if you try togging any settings the save button should work.

If you can play to the zone, how exactly are you unable to connect to it? Can you clarify, preferably with a screenshot?

Hello @Julian_Higgins,

To play to your Sonos zone using Roon, you must use Roon application. Roon is not available as a source in the Sonos app.


1 Like

Ok so this is not going to happen with zp90. I dont have any speakers sonos speakers but I have heard that play speakers can be made to work. Is there a special sauce for this to happen ?

I’m really not sure we are talking about the same thing.
We are talking about using the roon system to play to the zp90 and the speakers or system that is connected to it. Is that what you mean?

yes. Or to getting powered speakers and using those.

Powered speakers is what I use.
Once the 90 is setup in the Sonos app then roon should just see it.

The roon string shows in the play box - but no actual sound. Thought I might be missing a setting somewhere either in roon or Sonos but no luck finding an answer.

Support will keep working on it. But with a new release last night they might be a bit slow.

THanks for the help. I had thought that other users were able to get this to behave and I was just missing a parameter somewhere. Probably I am mistaken. Be a good idea to update the FAQ with the actual status of what works/does not as lots of Sonos devices out there.


It does work. Mine is playing right now. You just need some support to find out why yours doesn’t.

Yes exactly like that. And current software in the Sonos.

Hi @Julian_Higgins,

Just to confirm here - you’re starting playback in the Roon app and you have the Sonos zone selected from the Zone picker prior to starting the playback?

If so, can you please share a screenshot of your Signal Path when there is content playing to your ZP90 zone? Signal Path looks like this for reference:

“Roon lost control of audio device”
I can see the button for signal path but it vanishes immediately.
Still see the Roon…flac stream with an ip address at the end in the playing window for sonos controller ( using my iphone as device control)