Vodafone Germany w/ ISP-Supplied Modem/Router (Fritz!Box or Touchstone): Ongoing Discussion

Hi Sven,

Support likes each to have their own support thread. I have moved your post to a new thread. Please fill out the form below to provide needed information for Support.

Thanks

=============================================================

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

You are unable to connect to your core using Roon ARC because the port forwarding has not been accomplished. That’s why Rugby asked for more information so someone can advise you.

However, are you able to connect to your Roon core using your phone or tablet that is running Roon Remote version 2.0? Or can you connect to your Roon core with a PC or Mac running Roon 2.0? If not, what control device have you been using with Roon and have you updated it to Roon Remote 2.0?

1 Like

The Multiple NAT error looks like you have 2 routers in play.

My ISP insists that they have their “own router” direct to the fibre input for diagnostics, I then take a cable to my main router for ethernet and wi fi

Hence to open the system for internet requires BOTH of these to have open ports. So far I have not managed to do this . It looks like I need to talk to my ISP to get this done

Read this , it may help , it did for me

Hi Rugby!
Thanks for your answer.
Here my input to your questions:

  1. Who is your internet service provider? Vodafone
  2. Please list the make and model of your modem and router? vodafone router TG3442DE
  3. Do you have any additional network hardware, like additional routers or managed switches? No additonal routers or switches, just a LAN splitter so that I can have more LAN connections ( TP-Link TL-SG105 5-Ports Gigabit Netzwerk Switch)
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security? No VPNs or proxy servers used to my knowledge, only router firewall is active (but even with a deaktivated firewall it is not working) … please see pictures

  5. What machine are you using as a Roon Core, and how is it connected to the internet? I use a Roon Optimized Core Kit on a NUC10i7FNH, and is connected via LAN
    Roon software and Roon remote are updated on the computer, the mobil and as well on the NUC, and it is working properly. Only if I use the Roon ARC app it does not work.
    Thanks for the help in advance.
    Rgs, Sven

Do you know if Vodaphone has given you CGNAT instead of a direct IP? I would give them a call and find out what service you do have. If it is CGNAT, you can ask them how to get a direct IP address.

Hi @Sven_Schwarz,

My apologies for the delayed response here.

Unfortunately, your provider, Vodafone Germany, has implemented IPv6 across their residential tier accounts. While they do offer dual-stack lite as a workaround, it will only function if the home server from which you will be forwarding has a dedicated IPv6 address. At this time, Roon Cores cannot support IPv6 addresses, so dual-stack lite will not work.

This issue has unfortunately been broadly encountered by the Roon ARC user Community in Germany. See this thread and this thread.

However, don’t give up! You have several options for workarounds that are known among the Vodafone Germany user group for port forwarding:

  1. Replacing the Vodafone-provided modem/router (TG3442DE) with your own modem/router is known to prevent their carrier-grade NAT from blocking port forwarding in most cases. Many users have replaced their Vodafone-provided modem/router with a Fritz!Box gateway, for instance. See this thread: Vodafone Germany w/ ISP-Supplied Modem/Router (Fritz!Box or Touchstone): 502/504 Errors - #44 by Thomas_Forster

  2. Upgrade to a business contract with the option “fixed IP” (basically, a public routable IPv4 assigned to your router). This will cost a minimum amount extra each month in your contract, but it is a guaranteed solution.

  3. Try to get in touch with a support agent at Vodafone directly. Many users with older contracts have been able to grandfather in their original static public IPv4 address, or requested for CG-NAT to otherwise be disabled for their account. There are grey areas and exceptions to all ISP rules, so it is worth trying.

Please let me know if these workarounds are helpful. I’d keep on eye on the threads above that I’ve linked, as there are many other uses in your situation who have found solutions unique to their setup.

Thank you again for your patience.

2 Likes

It seems that it is not possible to use the Roon server over the Internet with the Vodafone Cable Fritz!Box. Arc reports permanently:
{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:“”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.178.1”,“found_upnp”:true}
}
What am I doing wrong?

You are doing nothing wrong. I have exactly the same issue with the same hardware and ISP (Vodafone). Tried every trick in the book. There’s no way to get it to work. Automatic port configuration is OK and confirmed in the router’s settings, but the multiple NAT error is always shown, although there’s no other NAT instance in my network. Seems to be specific to cable modems or that ISP.

If you do not have two routers in your home network, then it is likely that your ISP has set up multiple NATs in its network (Case B in the FAQ below). You will need to contact your ISP to get this resolved.

Looks like a large number of Roon-Users won’t be able to use ARC at least here in Europe/Germany. The ISPs surely won’t change their network architecture and routing schemes for them :slight_smile:

Have you asked your ISP?

Sadly, due to my past experiences with different ISPs here in Germany regarding other issues, that’s hopeless. Maybe I will give it a try.

The cause why it doesn’t work is addressed and explained in the topic below. This is exactly the common configuration I and many others have and not only specific to my ISP and router. Look here:

What is CGNAT and why it doesn’t work with ARC

Looks like there’s some homework for Roon waiting to be done to get ARC working for all users :slight_smile:

Just a suggestion to consider:

comes with a static ip.

  • 5 € per month

Thank you very much for the suggestion, Axel. I have this Vodafone tariff and router for private customers (without static IP). Your suggestion is for business users. Let’s see if Vodafone allows the switch …

No static IPs for residential users from Vodafone :frowning:
The IPV6 DS Lite Tunnel Vodafone is using prevents ARC functionality over IPV4:
Vodafone Germany and Fritz Box 6690 Cable: 502 Error in Port Forwarding Diag

@Antonio_Solaro
I know someone who switched to business account. It’s not a problem.

@Axel_Lesch
I will try to change. It’s not possible to do it online on the Vodafone site. The costs are the same as my residential account.

No need to get a business account… try this:
SOLVED: Do I really need a static IP to make Roon Arc work? - Support / Port Forwarding Help - Roon Labs Community

@ JST1963
Thanks for the hint. Unfortunately I cannot put my router in bridged mode because it also handles telephony. The Problem is my ISP (Vodafone) which handles IPV4 internet connections via a IPV6 DS Lite tunnel. These are derived internally (NAT) from the external IPV6 address. Therefore I have 2 NATs for internet connections. The only solution is a public external IPV4 address which my ISP grants only to business accounts and not to residentials. Otherwise I will have to wait until Roon offers a solution for such DS Lite Tunnel configurations over IPV6.