Volume Control is Fixed at Zero for Audio Devices

Roon Core Machine

Roon Nucleus +

Networking Gear & Setup Details

Using Ethernet/WiFi

Connected Audio Devices

Nucleus is connected via HDMI to my Bryston 3 DAC, onward to a Mac C49 pre-amp and then to a Mac power amp

Number of Tracks in Library

5000 or so tracks

Description of Issue

I selected Device Set Up for Nucleus HDMI A and chose Device Volume for Volume Control. Then Saved these parameters. At bottom of Audio screen I push the icon for the Device. The speaker icon next to the Device icon says Volume Control is fixed. I punch the gear, Zone Settings pops up. At bottom of page is “Audio Device”–reads Nucleus HDMI A. There are two buttons, Volume Limits and Device Setup. Volume Limits will not respond, while Device Setup will.
When I select at the bottom of the Audio page, My iPad, the speaker icon shows 100, and I can play music through the iPad.
Basically, it appears to me that all other devices are defaulting to Fixed Volume, and set at zero.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

On Audio Device bar, I cannot access Volume Limits. All devices except iPad, which I do not want to use as an Audio Device at all, show “Volume Control is Fixed”. When I try to edit this in Zone Settings, the
Volume Limits button does not respond at all. I have, somewhere in the maddening sequence, seen my Comfort Limit set at 0. When I try to increase it to, say, 100, it goes straight back to zero.
My Nucleus + is connected via HDMI to my Bryston 3 DAC
Something seems to be wonky with the Roon Remote controls.
Help please

Steven, I merged your two posts as they are similar. One post on a topic is heipful for support questions.

You can’t control audio volume via HDMI to an amp it’s fixed Roon doesn’t use CEC it just passes audio. You need to use DSP volume if you want this. Same goes when using a DAC unless it allows Roon control of its internal preamp if it has one. It can’t control volume on any other amplifier in the chain.

1 Like

Hi and thanks.
My Nucleus+ connects via HDMI to my DAC, which you include in your comment.
You are right about using DSP. So in Audio, I choose the DAC “zone”, then punch the gear button and get to Device Set Up. Go to volume control. Choose DSP, which in turn gets me to the page with Volume Control, which in this case actually responds. Note that the Guidance from Roon is that I will see a Volume Limits menu item which allows me to set volume limits. Problem is when I get to Volume Limits, remember I never see “Set Volume Limits”, just Volume Limits, the slider goes from minus 80db to 0db.
Comfort Limit reads 0. When I substitute 100 for 0 in the window, it goes back to 0. Down under Device Limits, it states that my device reports its limits between-80 and 0.
If you are still reading, I sent my Nucleus back to Roon a week or so ago because the app could not find the Nucleus. Roon sent it back, “fixed” I hoped, but now, although the app on iPad can find the Core, the other problems of fixed volume plagues the set up. The only “zone” which plays music is the iPad itself.
Any further thoughts or remedies would be appreciated. I am hoping for some Support from Roon, but so far NOTHING.

Oh and one more thing.
Bryston 3 DAC does not have internal pre-amp.
It is connected to a Macintosh C49 pre-amp, which is where I have always controlled the volume.
In the past, no issues whatsoever, which is why I believe Roon changed some settings that I cannot undo or adjust.

Dsp volume works on db 0db is max volume. Ou set volume limit to what’s comfortable and then set the max you want it to go.

1 Like

Steven, if I understand, you are trying to set a Maximum Volume using a range of -80 to 0 dB. When you type “100” it sets the Maximum volume to 0. That actually is correct. Volume levels, as you noted in this case, range from the lowest (-80 dB here) to 0, or unity gain (or the highest volume available on the device). Typing “100” won’t do anything in a decibel scale in this case. The highest/loudest volume is 0 dB.

Typically most users using DSP will set the volume at either -3 dB or -6 dB, representing either one-half or one-quarter respectively of the highest volume limit. If you set, for example, a -6 in the Maximum volume, is this saveable in the Settings?

No Roon cannot control volume of a preamp hard connected to an external DAC it’s an analogue out there is no connection that it can control. Roon can only control volume of Roon Ready devices or DACs that have inbuilt preamps.

Your C49 is Roon Ready so why you using an external DAC to it? This would explain why Roon controlled it before as you where controlling the Roon Ready in the C49 which would alter volume. Your controlling the wrong zone. But if your using a DAC into the C49 the Nucleus is the zone and it can’t control the C49 unless you group them together. Sounds like your c49 has dropped off Roon. Check the Audio settings in Roon to see if it shows up.

Robert,
It’s a mess. Sent the unit back a week or so ago. It returned, same serial number. First problem solved, as the app on my iPad can now find the Nucleus. New problem. No volume. Audio settings shows 2 devices connected to the Core (Nucleus); this is the case when there are no devices connected at all.
I will note that the label on one of the “Devices” when I received the unit back was MA5200, which denotes, I think, a Macintosh 5200 power amp. I have never owned one. The other device label is HDMA A, the output on the Nucleus I typically use. Despite the chat about not being able to control volume through the Macintosh C49 pre-amp, the fact is that I have, for over a year, done exactly that.
I did try your trick of adjusting the DSP volume, backing off the zero decibel setting on the slider.
Wont save. Can you attract the attention, please, of someone on the Roon support staff. I am beginning to think that when Roon “fixed” my previous problem, they created the new nightmare. I suspect that they swapped out a motherboard, perhaps, and inserted one with wildly different parameters. Frankly,
I would like to have the unit replaced, period. Such a great product, and so difficult to diagnose when it goes wrong. By the way, after days worth of interaction on the last issue (app could not find Nucleus), no one had any idea of what was wrong, so sent an RMA. This is all pretty discouraging.

Steven, the C49 is a Roon Ready Preamp that means it can play from Roon over the network or it can be used as a DAC via its USB input. Why are you connecting the Nucleus to a DAC that feeds into the preamp. Sorry but your setup isn’t making much sense. At some point you must have been using the C49 as a Roon endpoint for controlling it’s volume either via USB or network as I have said already you can’t control it from the nucleus connected to an external DAC as it has no idea about your preamp.

Can I suggest you reboot you core, network and c49 when all up, please show a screen grab of the audio devices Roon sees and you have enabled so we can have a better idea of what your doing or have configured.

Hello and thanks again for the genuine effort to assist.
New development. While the app has for days “discovered” not one but two “zones” or “audio devices”,
it now can see only my iPad, which it happily plays…I have never seen the iPad as an audio device in previous use of Roon. Roon does not, however, see any other devices or zones. To your point, sensible or not, my standard set-up has been stable for more than a year: HDMI into Bryston 3 DAC, balanced outputs from DAC to C49 balanced inputs. I am clearly no pro, but I imagined that the digital output of the Nucleus + was converted by the DAC and fed as analogue to the pre-amp. I have another set up, using Aurender, which in turn runs through a stand-alone DAC, thence to a Pass Labs pre-amp. And that continues to work just dandy. I have rebooted everything, as suggested, already.
Further, the “device” or “zones” (both of them mystery, which continue to show up on my set up screen)
can be enabled or disabled, but still remain, and at this point, remain “unseen” by the app.
I think it is a reasonable hypothesis that the Nautilus remains wonky. I still await an opinion from Roon
Support, days later. And I do thank you as the only interested respondent.

Steven, can you please take a screenshot of what you are seeing in Settings → Audio from your Core? There may be a network issue in play here also.

Will do. Traveling now. Can you advise me how to get direct contact with Roon support?

@support monitors these posts, this is the support model for Roon.

I just sent a screen shot to "community@roonlabs.com
In the subject line, I added Attention Robert_F .
Please let me know if you receive it.
Note that there are multiple devices under “Connected to Core”
I have no need for these devices to be “connected” or at least none except my music system.
Can you please moderate this to someone in support. They may be “monitoring” but so far, no assistance.
Also, please do not delete the topic.

Just had the screen shot bounce back.
Please advise on how to send the requested screenshot.

Hi @Steven_Brooks ,

Thanks for reaching out and for your patience here while your case reached our queue! I’m looking over your account here and I notice that it looks like Roon detected your Apple TVs, Sonos, iPad, and HDMI zones properly.

I also enabled diagnostics on your Nucleus and I’m not seeing anything notable in the error logs at this time, the unit looks to be working as expected.

Please note that you can’t send screenshots, you would have to post them on the forum using the “image button” when typing out a post, please see this guide:

Looking over your RMA notes, it looks like there was indeed a motherboard swapped. Nucleus runs a standardized Operating System package though, so the motherboard parameters should pretty much always be the same between units, I’m not seeing anything wrong in this section of your Nucleus.

Can you please share a few screenshots of this issue or upload a short video? If you need a place to upload the video or are still having issues with the screenshots, you can upload them to our Media Uploader, linked below:

https://workdrive.zohoexternal.com/collection/nqcgjac23027d90a441bda2c314de49d7958a/external

Hope this helps!

1 Like

Thanks a million for jumping on this. I have uploaded one screen shot to the Zohoexternal.
Can you see it?
First, please do not automatically delete the topic tomorrow!
I hope amid all of the frantic posts I have described the set up in a helpful way.
The ethernet connection of my Apple TV, Sonos soundbar and Roon Nucleus is via a NetGear multi port gizmo. The Roon output is via HDMI cable to the HDMI input of my Bryston 3 DAC.
What is bizarre is that this has never happened in the past. One year plus of seamless operation.
I love the software or would just junk the whole thing. Problem is, other “players” are much more expensive and have much inferior user interface.
I note that the Apple iPad “zone” says “Audio will play out the default device”.
Playing around I have now managed to delete the Apple iPad as a zone. Gone.
Bottom of Audio page now says: No audio devices found.
“Manage Audio Devices” won’t function, obviously I suppose.
I would be most grateful if you can solve this, as I am pulling my hair out.

Hi @Steven_Brooks ,

Yes, I do see the screenshot, I will re-upload it to the thread here so that we have it for easy reference. Note, you can also drag and drop pictures into a reply box on the forum and that uploads them to your post.


The issue here is that you have accidentally set your Nucleus HDMI zone as a Private Zone, you will want to uncheck this so that other Roon Remotes can access this zone.

I’m still seeing it show up as a zone in your diagnostics, but if it doesn’t, you can try to delete the iPad app and re-load it from the app store. Failing that, I would install Roon on a PC and connect to the Nucleus Core and control it that way, at least for the weekend.

If you run into any issues after following the above instructions, I would try to post with as much detail and screenshots as you can on this thread here, so that others may chime in with helpful suggestions until Monday when we are back in the office. Hope this helps!