Volume settings all goofed up

In my trial of 1.8, which is going just as disappointingly as the versions before it (only trying to make sure I can control Tidal from my phone to play Tidal on my Mac Mini…while “Tidal Connect” is still to be created), I mistakenly edited the Device Settings. Now whether I “reset” or “back to defaults”, nothing changes. The volume markers are disabled and my device, a Schitt DAC connected to my Mac Mini, only sees full volume. What the heck? How can this basic thing be a bug?

Volume is totally disabled

Where should I change this confusing and over-done UI so I can control the device volume as before?

I thought that it is normal (volume control is fixed). :slight_smile: I also can´t control the volume of my DAC in the Roon software, but with the help of my volume control on the DAC himself.

Does this help?

BTW - Frustrated hissy fit is not a good strategy.


That’s not the way the DAC works. No remote. It worked just fine for three days until I just tried to explore the Settings because Tidal’s “Master” songs are still playing as normal in Roon. I’ve restarted Roon, restarted machine, etc.

“Volume is fixed” means volume cannot be controlled by anything, not mobile, not the Roon on Mac Mini either. It’s the max volume on the speakers, which is stupid.

So, to repeat the question: how to un-fix the volume? Reset to default does nothing.

Sorry, there’s nothing in that page that’s outside the obvious things a user would try. The issue is that volume cannot be "un"fixed. Where would one do it? All the options for Min/Max are totally disabled, and remain so even after one resets.

Whatever the confusing nomenclature of Roon, I want the ability to choose volume on the device while using both my iPhone, and the Mac Mini on which the Roon is installed and which is connected to the DAC. Simply, I want this “volume is fixed” to go away and the usual volume meter to reappear. How?


To be more precise, both these things show “Volume is fixed” message:

  • Device volume
  • Fixed volume

When I change to DSP volume, it shows me the following meter with volume:


This -Xdb stuff is not what I’m looking. Just want to go back to numeric meter as usual. Welcome any pointers. They’re not on that Help page that you kindly linked to.


I have one DAC that works with Device Volume but my Schiit Gungnir Multibit is not one of them. I get exactly the same results that you describe with your Schiit DAC. I know you said you were able to use Device Volume for a couple of days but to be honest with you, I don’t quite understand how. It’s not designed to work that way. My PS Audio DirectStream DAC also ignores the Device Volume/Fixed Volume settings, the same as my Gungnir.



Many devices don’t allow volume control from an app.


Have you tried to uninstall and then reinstall?

EDIT: Looking again at your posts and the responses, are you sure that your DAC has hardware volume control? It looks like it doesn’t. In which case you would need to use the DSP Volume control. What model DAC do you have?

I’m pretty sure — and I’ve mentioned above — that Schitt DACs don’t have volume control.

I have had it working even in the previous version. The DAC is the default system sound setting. The regular numeric volume has always worked. Anyway…

You’ve said that the DAC doesn’t have a remote, that’s not the same as saying that the DAC doesn’t have hardware volume control.

If your DAC doesn’t have hardware volume control then I wouldn’t expect Device Volume to work as this is the software directly controlling the DAC hardware volume control (the “device” in Device Volume).

Which Schiit DAC are you using?
How is it connected to the Mac Mini?
Where is your Roon Core located?

Schitt Modius. Not that it matters, as all of them essentially are similar functionality wise.

It’s connected to Mac Mini by USB.

Roon Core is my Mac Mini. That’s where it is, the software.

Ok. The Schiit Modius does not have any form of gain control. There is nothing for Roon to control, so ‘fixed’ is all you are going to get, BUT…

I suspect that previously you were using the Mac’s audio subsystem as ‘output’ - which Roon may be able to control with a 0-100 slider - which was driving the Modius. I’m not a Mac user so it’s not something I can try myself.

What do you see under Roon settings/audio? What outputs have you enabled?


Schitt is the default System Output on my Mac Mini. I’d be happy if Roon can just use my System Output. But it doesn’t. The volume keeps disappearing. Spotify and Tidal have no issues. Plex has no issues. Youtube in Chrome/Safari has no issues. Only Roon is attempting to do some magic that’s totally silent.


In Roon, System Output settings:

This sometimes works. Then it disappears and Mac is trying to play sound on its own, not passing to Schitt. And btw, if I change the device to Schitt, it plays the song that was playing on System Output and continues to play it without any volume control. So down below on the right it’s now saying Schitt, but volume dial has no effect on sound.

I’m sure there’s some supergeeky audio intelligence happening here. Let me speak as a user: this is REALLY dumb.

Please Room devs, please get this magical tool of yours to play sound as all the other apps play. That’s not much to ask for.

Volume settings are working as expected.

I think this is your problem…

Do you see any error messages when this happens?
Is the Mac doing anything else while you are playing?
Do you have exclusive mode selected for system output?

Spotify, Tidal etc. use native software controls in their apps. This means that the app itself is altering the volume. This will always work, obviously, but this type of software control can lead to audio degradation.

Roon uses a different set up, designed to minimise audio degradation. If set to “Device Volume” Roon will use the onboard volume control on the chosen output. That’s why it doesn’t work with your DAC.

If you use “System Output” (as you’re tring to do), this should enable you to use the usual system volume controls via Roon. However the fact that you’ve got your system set up to play via the USB DAC appears to causing some problems. This method of volume control is not ideal from the point of view of audio quality anyway.

Basically, if your DAC doesn’t have hardware volume control (which it doesn’t), DSP volume control will offer the best solution. It will preserve the highest level of audio quality and still allow you to alter the volume during your listening session.

1 Like

Presumably your Modius is connected to an amplifier of some kind which outputs to speakers or headphones. In this case, Roon expects you to use the volume control on the amp. If the amp doesn’t have a volume control then your only option is to use DSP volume control.

Hi @NearlyNormal,

Thanks for giving Roon another try - I’m sorry the experience with Roon 1.8 wasn’t what you had hoped. I’m equally sorry for how long it took us to get back to you - I sure wish it would have been sooner.

It looks like in the meantime a number of our subscribers have chimed in with very valuable insight clarifying the way Roon works and how would that apply to your case. Thank you a bunch @Dave_Richardson, @Frank_Rahde, @xxx, @SukieInTheGraveyard, @David_Gibson and @AndyR - we’re grateful :pray:

Is there anything we can do to help now? :nerd_face:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.