VPN now has an issue

Here is a quite special problem I discovered. Maybe it’s by intention ?

I can easily access Roon via VPN, and it works fine.

However, now the picture below isn’t available when in remotely connected.

Which means I can’t access it as a zone. (Privat Zone on/off didn’t help).
Doesn’t matter if enabled or not.

So is this a bug ?

Roon isn’t supported over VPN only local network currently so your in the realm of tinkering here and likely to have oddities. Endpoints need to be on the same vlan to be usable so what your getting is standard behaviour for a VPN connection.

Please read the SW release notes. And my VPN works as I’m on local network. I’m allowed to have my answer replied by Roon.

Roon works very well over VPN if done right.

We can discuss standard behavior for a VPN connection in the official forum where there is one or two VPN threads.

Hi Roon team

Possible to have a feedback on this issue ?

It’s a possible bug, and we can still use this area to post issues.

It’s still an error, unless I’m doing something wrong in how I configure the VPN.

Hi @danny
Thanks for answering. I think I must explain how and why I use a VPN service.

My DHCP server and firewall is a SW named:

I’m using this as a RoadWarrior. This means I can connect to my home network any place in the world by enabling VPN on my iPad. Or iPhone. (IPSec in this case)

So I have no problem seeing Roon, and the rest of my network, but the issue is that my iPad won’t show up as a explained in first post.

So I don’t think NordVPN can help in this case. Agree ?
I think you’re talking about split tunneling. Which NordVPN can help with, and not what I’m after.

So I’m trying to understand if there may be a firewall setting I need to do or if there is a minor bug in either iPfire or Roon ? Or even Roon have done something by intention? It may even be an Apple thing :grinning:

I must say I suspect more Roon than iPfire, as I can access my whole network as I’m at home when away, but I may lack some technical understanding on the matter.

The goal is of cause to add Apple CCK, and play music away from home.
(Especially in my car). But as said in first post, my iPad isn’t showing as an audio device.

Your help is much appreciated Danny. Maybe one of the Roon developers can look into this.

Below is picture with and without VPN enabled. (VPN over cellular). So i can play to all other devices using VPN.

I think maybe the source to the problem is here wiki.ipfire.org - Global Configuration

I also asked over at iPfire community: