VPN: step-by-step

Yes - thanks. I’ve seen that one can swap licences between two cores. I thought since I’d set up Roon to access to the files on my NAS already - that it would be easier / best for me to just maintain one, centralized library. So that, matched with the fact I like to fiddle and fuss around with this kind of stuff. :wink: We’ll see what happens…

1 Like

Just didn’t want you wasting time… but fiddling with tech that’s different :grinning:

1 Like

Hi,

Interested in how you got this running. I am using a Synology router and have tried OpenVPN server on the router itself and on a separate server. Using TunnelBlick as my OpenVPN client. Have no problem with the VPN itself but can’t get Roon to work. Did you use TAP instead of TUN so your office endpoints are on the same subnet as Roon at home???

Thanks. That’s actually a really basic/standard configuration. I have the same Synology OpenVPN setup and also using Tunnelblick and while the VPN is fine, Roon doesn’t work. Attached are my same settings and Tunnelblick… can you attach a screenshot of your Tunnelblick config? what versions of OVPN are you using clientside?

Must be something else at the router level. Why are you using ‘port triggering’ instead of ‘port forwarding’ for 1194? 1194 is the port for the vpn itself and nothing to do with Roon ports/broadcast groups etc. What are you IGMP settings on your Netgear router??

No of course Roon has no concept of vpn access or not. But you are implying that the roon core is communicating to your vpn client from a virtual 10.8.0.x IP address, (likely 10.8.0.1) as that is the same address that your OpenVPN server is running on.

My core is running on a mac, not the same IP/server as my gateway/router … yet I am able to successfully run an openVPN server on both it or on my Synology router. I can route all internet traffic or not, etc, etc. The VPN is not the issue per se. Lots of other people have tried getting this to work over OpenVPN and have the same problems.

It’s unclear how it works at all if the Roon core and the Roon endpoint aren’t on the same subnet. Maybe there is some right routing such that the Roon core will send discovery packets over the virtual 10.8.0.x subnet as well as the local 192.168.1.x subnet. That’s the only way I think it is working in your case. For some as yet to be discovered reason.

Hey guys,

I’ve tried everything but I can’t get the Android Roon app to get past “No wi-fi connection”. I’m connecting to my VPN find on Android, however the Roon app itself does not appear to even attempt to look for a core if the Android system is not connected to a wi-fi connection. Driving me nuts.

Proof that my VPN is working:

  • I connected to my home wi-fi network
  • I successfully connect to my Core on my Android Roon app via my wi-fi network
  • I disconnect wi-fi while Roon app is still running
  • Now I’m on 4G, but with VPN connected
  • I can control my home Roon Core via 4G now
  • but this disappears when the app is restarted
    • can I force the app to look for a core somehow even if not on a wi-fi network?

Thank you!

1 Like

I don’t think so.

I can connect to my core at home via VPN on my iPhone. That works, but my iPhone does not show up as a player, so listening to music on the go is not possible at the moment. Is there a way I can get this to work?

Hi mate just wondering, are you connected to a wifi signal with your phone, or purely 4G? Thanks

Hmm strange how some can get it to work then, I must be missing something

Hi @Squeezemenicely,

Exactly same problem, did you find a solution?
thanks
David

For what it’s worth… I have a Windows Server on my network and am able to connect via a PPTP VPN from anywhere and have Roon work fully including controlling all playback at home and also streaming audio to my phone.

No, sadly not, I used to run LMS and had iPeng on my iPhone - that worked perfectly via VPN. Shame that this is not possible with Roon.

I found a solution, activing the IGMP snooping on my router, all works fine

I got Roon working over VPN very easily using the Softether VPN server on windows 10 which is running on the same machine as the Roon Core server.

I’m using the standard L2TP/IPSEC VPN client settings that are built into both IOS and Android with no problems.

Im using Google Wifi Mesh network at home behind a broadband router in bridge mode, so I just had to add some port forwarding rules for the VPN server and that was it.

It even streams dff and dsf 352 DoP files without resampling or any stuttering.
I do have 100Mbit/40Mbit network that helps a lot with that! (40Mbit out from my house)

If anyone is interested I can create a video guide and screenshots.

1 Like

Please do so

+1 :+1:
Please do!

Thanks @Hilton_Kelly !

First attempt failed for me but port forwarding UDP 500 and 4500 plus making sure to login with username@vpnhub on the VPN client (iPhone) did the trick.

I don’t get it, there are loads of users writing that they cannot get vpn on iPhone to work with 1.6 and ever so often someone writes, it works perfectly. So please you people who have it working on iOS give the rest of us detailed instructions.

I have a VPN at home via my fritzbox router and absolutely everything I want to access from outside my home works perfectly, as if I were actually at home in my network. The only thing I could never get to work was Roon. In my iPeng days also everything was easy.
What is so different about Roon and why has no one ever posted a truly detailed guide? The discussion has been going on for years.
So clever people please help us not as clever people to have Roon goodness out on the streets.

I suspect the people who are able to get this working are running the roon server and the VPN server on the same host. Since it is also the VPN server it is multihomed into both subnets. Is there anyone who has this working fine who isn’t doing this?
If only they built a simple vpn server into the rock…

1 Like