Waiting for NTP synchronization

Just finished moving my Roon Core to a Rock Nuc, and thankfully (with the help of this forum) have worked out a few (but major) issues. All of my Ropieee devices (I have several) but one works fine. That one is used only for control purposes - has a display but no DAC and no Amp. It worked well before the change of Roon Core machines. Now it will not finish the startup script - it “hangs” at the third phase - NTP synchronization.

Any ideas?

Does it have internet connection? That’s required for the ntp sync.

Yes. Ethernet. I just tested it and it is up and running (the internet, not the Ropieee). I can access the affected Ropiee Pi machine at its IP address (on the same network as I am using now to send this message). I have tried rebooting, restarting, and pulling the plug - all of which end up with the same result - the machine stops its script at the third stage of booting - waiting for NTP connection.

Are you using a fixed IP address or dhcp?

Static… should I switch to DHCP?

I found that got me past the hang…Harry is looking at this issue so it might be something more than he thought initially…I think its supposed to be using the gateway as the DNS address but something seems to me to be broken.

Hi @Ronald_Lyster,

Glad that @wizardofoz is around to remind of some things :wink:
But yeah, could you try with DHCP? There might be a problem with static IP addresses and routing.


Yes! Thank you to Harry and to wizardofoz - that worked.

Great. I’ll make sure that bug is fixed in the next release.

1 Like

He @wizardofoz and @Ronald_Lyster,

I’ve looked into this tonight… and the annoying part is that I can’t reproduce it.
I’m sure it’s related to the static configuration because you both had the issue, but when I configure a static IP it just works.

So… can anyone (and wants to as well of course :wink: ) try to reproduce this?

Looks like this isn’t the end of the matter (unfortunately), but perhaps a clue as to what is going on. The probem has arisen again. Last time (with your help) I got things working by enabling the Ropieee extension. Now Roon cannot find the extension (there is nothing for me to enable). How do I get that extension back? I am using DHCP.

Can you send me feedback?

Well… Certainly happy to do so. Maybe my problems stemmed from a bad router? The latest issue arouse after I installed a new router - but now that 90% of the router installation issues have been handled, the Ropiee extension appeared again - and I enabled it. For now, things appear to be working fine once more.

I guess that was just wishful thinking… Woke up this morning and the problem arose again - but this time the boot-up message included the statement that Ropieee was running - just waiting on NTP synch.

Tried rebooting the core server, but no luck. The Ropieee extension is missing once again.

So, you’re on DHCP?

And second question: how is your update scenario configured? Are you on automatic updates?

If I have a choice in settings I always go for automatic updates. Yes to DHCP.

Ok. Can you send me feedback so I can have look? Go to the ‘advanced’ tab on the webpage and press ‘send feedback’.


Logs have been sent to RoPieee HQ with unique identifier 35ec25471305a0bb

Hi @Ronald_Lyster,

You’ve been bitten by a bug :frowning:

I’ve fixed it, your system needs to update. Can you reboot it? it will then pull in the updates after 15 minutes or so.

Thank you. However, after rebooting I haven’t seen the Ropieee extension show up. I sent you another set of logs- unique identifier 8f229fc40c51c201.

I just tried another kind of rebooting - not the “system” (which I did before) but the Roon Remote Extension. The extension now appears and I’ve re-authorized it.