"waiting for remote core" after a router change ZTE ZXHN F680

Core Machine (Operating system/System info/Roon build number)

PC MSI operating system Windows 10 /i7 processor/ Roon Version 1.7 (build 710)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Roon core connected to Router ZXHN F680 via LAN.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Streaming through LUMIN D2

Description Of Issue

Ever since my change of the router for a two-band one I have been having difficulty trying to connect to the core using my Android devices. ROON core runs smoothly with no issues of any kind but not being able to operate it remotely does not facilitate matters at all, to put it mildly. All devices work on the same network, obviously. I suspect the router change might have something to do with the trouble I am experiencing but since the router itself can only be accessed by the internet provider I need to know what to tell the guys on the other side of the line and what functions to disable/enable once they access the router’s settings. Anybody having the same router model and experiencing similar issues? I would be grateful for any advice on this issue. Best regards. Tom

If you are able to login the router:

  1. Turn off “Enable Isolation”:

  1. If that does not work, try experimenting with the IGMP setting:

  2. In case this cannot be solved, ask about possibility of disabling its WiFi, then you can buy another WiFi access point.

1 Like

Hello @Tomasz_Michura, and welcome to the community! Wklie has a great idea here, let me know if that resolves the issue.

Hi. Thank you so much . I am just trying to resolve the issue with my internet provider as, strangely enough, only they have access to the router (super fast fiber connection). They have tried to do some adjustments onboard the router but so far no positive results. It is really irritating as they replaced the older router with a seemingly much more efficient version and it does not work!
I appreciate the “another router option” and “WiFi off on the provided router option” suggested but it means additional costs and more hustle and bustle with configuration.
I will keep you updated!


Again great thanks for your reply.
The technician from the network provider has informed me the “enable isolation” box was ticked off. Does it mean I should ask him to tick it on?
I really begin to go insane here. :grinning:
Thanks in advance.

It has to remain off.

That means something else is causing your problem. It’s quite likely that the router is not passing multicast packets. In other brands of routers, IGMP setting may help.

Maybe I could ask them to tamper with IGMP options if that is possible?

Yes. The objective is to let the whole network including WiFi receive all multicast packets.

1 Like

Hello @Tomasz_Michura, we recommend you enable IGMP proxying in our networking guide so this should be a good step if that is currently off.

Hi guys,
While waiting for the net-provider IT team to give me an answer whether the changes of IGMP options are possible here can you please provide me with a hint which router (brand, model) would function ideally in my system with Roon. I could then treat the ZTE f680 as a bridge with its wifi off and connect another router/access point to it. I hate compromises.
With best regards


Hello @Tomasz_Michura, while I don’t have any specific recommendation I’d recommend taking a look at our networking best practices guide when considering a possible router upgrade.

Thank you all for your comments. The issue has been resolved. The ZTE router settings as suggested in previous entries. Now multicasting creates no problems any more and I have gained full remote control over the Roon Core. Life is better now. Merry Christmas. :wink:

I need the exact setting changes the ISP apply to the ZTE router please.

I have just sent them an email asking them to specifically state what changes they have made. As soon as they have replied I will forward it here. Please bear in mind they are slow in answering plus it is almost Christmas time. However, I will be nagging them anyway.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.