Want to trial Roonserver on Windows Server 2016 Core - but the app won't connect

I’m trying to set up Roon to evaluate it but no matter which device I use, it sees the Roon server but sticks on “Initializing…”

Details of setup:
Roon Server 64bit (just downloaded from your website to trial it)
Installed on Windows Server 2016 Core
Audiophile Optimizer v2.20 installed to give Roon support
No other software installed
Firewall completely disabled

When attempting to connect to the server using the Roon app the connection sticks at “initializing…” (I’ve tried Android and iPhone as well as Roon installed on another PC on Windows 10).
I installed the Roon Server on a Windows 10 machine on the same network and I am able to connect fine using the app, so there’s an issue with the Windows Server 2016 Core setup. And it’s Server Core I want to run it from.

The server PC is a fanless box using Asus H110T motherboard with Intel i7-7700T and 32Gb RAM.
The router and all other devices on the network can access the server, so network is fine.
Windows Server firewall has been disable via Powershell.
Not set up any music source yet as I’m unable to manage the system.
My player is a Sonore Signature Rendu SE.
Network is wired and server has a static IP address.
Router is Netgear D7000 with latest firmware.
AQVox SE network switches are used to connect the player to the server and server to the router.

I run Logitech Media Server off another boot partition on the same Windows Server 2016 Core machine with an identical setup and it works fine.

@support --> Any thoughts on what’s stopping the app from connecting to Windows Server 2016 Core when it works fine with Roon server on a Windows 10 machine?

Did you run the ao -wasapi command? I don’t think Roon will connect without doing so.

I never was able to get Roon under AO 2.20 to work in WS2016 core mode. I ultimately gave up and run Desktop Experience but selected RoonServer as shell in AO. You can’t switch between core and desktop experience in WS2016 as you could in WS2012R2 so be aware of that. If you want to follow along on all my issues in getting WS2016 core to work with Roon, read the computeraudiophile.com blog with highend-pc, alias AudioPhil from AO, starting near the bottom of page 6. I’m jrobbins50 in that forum. https://www.computeraudiophile.com/forums/topic/26766-how-to-roon-and-roonserver-on-windows-server-2012-r2/?page=6

Also, make sure switches are not in managed mode. That’s apparently another problem area for Roon connecting. JCR

Many Thanks Jeffrey.
Impressed with the fast reply and instant fix – that’s what I call “support”.
Ran “AO -wasapi” and AO asked if I wanted to install the option (tells you it’s experimental).
The system rebooted and Windows did a brief setup. Now I can connect to the server from all my devices.
About to start my trial and see how Roon compares to LMS which I’ve used for many, many years…
I’ll try re-enabling the Windows firewall to see if it still works.
** Nope, can only connect when the firewall is disabled - would be useful to have the firewall settings for Roon as a reg file that could be imported?**

Good! Glad that fixed it for you. JCR

By default Windows Server firewall properties are set to Public and it has to be changed to Private or disabled for it to work. Now from the GUI version it is easy to change.

With Core you will have to change it through Powershell.

Here is a link with regard to Powershell and changing the firewall setting to Private.

Another link here from Microsoft.

Hope this helps

Cheers Mike, that’s done the job.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.