Was working fine, then not so much

Mac Mini , OS 10.13.6

Mac finds the NAS

Roon does not find my library, or whatever you call it, my music
storage location is unavailable:

Honestly, everything was fine, now it only looks in Tidal for music.

Thanks for reaching out, @Peter_Armstrong!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices (particularly the NAS and the Core) are communicating.

Have there been any recent changes to your networking setup?

Since noticing this behavior have you tried rebooting your Core machine, NAS, and networking hardware?

If there is any antivirus or firewall on the Core machine, try disabling them and let us know if that yields any change.

Have the login credentials for the NAS share been changed? If so you can edit the watched folder by clicking on the 3 dots and update those fields.


Maybe your nas has changed IP address? You Mac is accessing via a name and Roon is using IP address based on your screen shots

Thanks Dylan,
this is a home set-up, TP-Link Ac 1750 modem, to a Harris Surfboard SB6183, that feeds a D-Link switch sending cable throughout the house. The Mac Mini has the Core, the QNAP SilentNas is adjacent to the Mini. Both are connected to the network via separate wired connections.

There have been no changes to the Network setup. There there is no firewall or anti virus software on the Mac Mini/Core but I’ll double check.

I have rebooted both the Nas and Mini and have restarted Roon. No change.

I don’t see how to edit the watched folder. From what I can see Roon says it is unavailable.

The only event that happened recently is that my Tidal account was suspended and restarted due to a credit card snafu. I don’t see how that would be relevenat, but what do I know?

Thanks, I don’t understand how that may have happened (but I don’t need to understand). I don’t know how to check or change that.

Sometimes rebooting things with dynamic IP addresses can have the address change. Your srorage address setting in the Roon settings is an IP address that might have changed now. In your Mac finder info shot it’s using a named address.

You need to log into the nas and see what IP address it has, and how it’s being assigned, most likely by your router using DHCP.

1 Like

Difficult to do if the NAS address has in fact changed.:wink:

That’s OK, I know you meant to say “log into the router”, but maybe the OP doesn’t.

1 Like

You could try changing \\\Multimedia in Roon settings with \\NAS1862._smb._tcp.local\Multimedia. Double check I’ve copied this correctly first.

1 Like

Synology has a find web address you put in ya browser… maybe there is a qnap equivalent like find.qnap.com ?

Thanks, but Roon says that’s an invalid path name.

Go to your browser and get on your router software. Do this by entering, most likely,

Once you’re in the router’s software there will be a list of devices and their associated IPs. You should see the NAS and its IP.

Alternatively, if you have a tablet, use the app Fing. It will show you the same thing.

Thanks for giving that suggestion a try, @Peter_Armstrong!

As Slim_Fishguttz mentions above, you can confirm the IP address of the NAS by using an app like Fing to scan the network. This way if the IP address changed you can find out what it is and update it in Roon.


I highly recommend fixing the IP address either in the NAS (staying out of the DHCP range the router is controlling) or in the router you can reserver IP addresses in the DHCP range for specific devices you don’t want changing.

Thanks for the help. Indeed, the IP address has changed, I’ve determined what it is, but I can’t figure out how to tell Roon to find it. I’m sure I’m overlooking the obvious. I’m tired of watching television and listening to AM radio. I want my music back, please surrender it Roon.

Hey @Peter_Armstrong,

Since the IP Address changed, you’ll want to change the watched folder path from \\\Multimedia to the new IP address. You’ll also want to make sure that it’s a static IP so you don’t run into this issue again.


As discussed in another post, if you’re going to set a static IP you really should also reserve that IP in your router software else you will run in more mysterious problems.

1 Like

Indeed I have determine the new iPhone address.how do I make Roon find it?

Hey @Peter_Armstrong,

See the screenshot from your earlier post below:

The current watched folder, \\\Multimedia needs to be updated to use the new IP address. This can be done by clicking the 3 dots to the right of that watched folder and choosing Edit. From there you can select Browse and choose the correct path to use.

Let me know if you have any other questions about this!


Thanks, found it with Fing. Router ( TP Link) software doesn’t show a list of devices, curious.

Ok, I click the three buttons. I click edit, it doesn’t let me change it.