WASAPI Exclusive mode on Dante Virtual Soundcard not working properly

Core Machine (Operating system/System info/Roon build number)

Windows 10 / current Roon build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet / Netgear switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Rednet 3 via DVS

Description Of Issue

With Exclusive mode enabled on WASAPI output for DVS, I would get sound, but it doesn’t play properly. ASIO mode and WASAPI non-exclusive mode play correctly.

Hello @Huan_Nguyen,

Welcome to the forum.

What exactly do you mean by “doesn’t play properly”? In what sense does it not play properly, are you getting dropouts? Does the track suddenly stop? Audio distortion? Missing channels?

It sounds distorted, like it’s not able to keep the buffer filled properly and dropping out on a regular interval. I can try to record it later if needed.

Hello @Huan_Nguyen,

Yes, please do make a recording of the behavior, it will help clarify the issue.

Recording present here: https://soundcloud.com/huan-nguyen-620127532/roon-wasapi-1

Hi @Huan_Nguyen,

Thanks for sending that recording. Does the same behavior occur when using exclusive mode with WASAPI in another app (such as TIDAL/Qobuz/Foobar)?

We did a bit of research and found other reports of issues on WASAPI for DVS, if the ASIO driver is working as expected you may want to keep using that one instead:

I do not see the behavior for foobar or JRiver, but I have seen it in both Roon and Audirvana.

Hi @Huan_Nguyen,

If this behavior occurs on multiple apps it points further towards the driver as being problematic. Are you certain that foobar and JRiver are using the WASAPI driver in Exclusive mode for your tests? As I mentioned earlier, if ASIO is working fine you may want to keep using that driver instead.

I am certain that foobar/JRiver are running in WASAPI Exclusive mode.

I’ve investigated that a bit as I have exactly the same problem. So it works with exclusive mode in the Tidal desktop app and in Foobar2000 as long as you’re using the sampling rate that is set in the Dante WASAPI driver in Windows 10. In Roon it’s not working at all …

Hello @Huan_Nguyen,

Could you try reproducing this behavior and then sending us a set of Roon diagnostic logs? Use the “Option 2” instructions as detailed in our KnowledgeBase article.



This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.