Web Display Gets Stuck On Last Track, Requires Core Reboot

Roon Core Machine

Synology DS218+
Roon 1.8 (build 814)
DB stored on USB SSD

Networking Gear & Setup Details

Google Nest Wifi (mesh)
Synology connected to router via ethernet

Raspberry Pi 4
Raspbian Buster (desktop install)
Roon Bridge 1.8 (build 814)
Connected via Ethernet
chromium-browser --kiosk http://<Roon_Core>:9100/display/

Connected Audio Devices

Raspberry Pi 4
Raspbian Buster (desktop install)
Roon Bridge 1.8 (build 814)
Connected via Ethernet
chromium-browser --kiosk http://<Roon_Core>:9100/display/
USB → Schiit Modi
RCA → Schiit Magni

Library Size

~60k tracks

Description of Issue

I’m running a headless Pi 4 streamer to feed my Schiit headphone stack. Recently I added a 3.5 TFT display to the streamer, full details and a screenshot in the post linked below. I’ve noticed a few times that when I pause the Roon stream from a client for the evening and come back the next morning the Roon display is stuck on the last track from the day before. It doesn’t happen every day and when it does happen it persists between reboots; I can SSH into the Pi and do a graceful reboot and the web client comes back on the same track and doesn’t change with new tracks from Roon (although they play through the streamer just fine). The only way to reset the display is to restart Core on the Synology which fixes it every time.

When it happens again, is there anything I can grab from logs to find an error, or another way to reset a display? Before a restart I’ve tried to reset it from Settings → Displays with no luck and stopping the display from the volume control in Roon and restarting it, also no luck.

There are a few posts in the forums of others having similar issues over the years but I don’t see any firm resolution. And while my issue has happened a few times since adding the screen about a week ago I can’t force the issue to reproduce.


Hi @rcrawley

If you use a different display do you see the same issue, or is it limited to the Pi 4?

I’ve never seen it on any of the others (Chromecast) but I also haven’t displayed to any other screens 24/7 like I have with the Pi streamer. I’ve also never seen it stick on my Cambridge 851N which streams most of the day but also doesn’t stay on 24/7. So no other good test data to compare, unfortunately.

Thanks for confirming, @rcrawley. When this display is in this state, if you were to launch a separate display at this time, is it stuck in the same stuff as the Pi or does it work as expected? What I’m hoping to understand is if something is failing in what the Core is sending or if something is getting stuck specifically on the Pi.

@dylan I just encountered this again; the Pi display was stuck this morning. When I click on the volume icon to select a display I see the Pi in the list (schiitstack) but I can’t click on it, nothing to do, and it’s not listed as a configurable display in Settings → Displays. I rebooted the Pi but no luck, same result. And on the Pi if I connect to the /display/ URL I just get the black screen displaying “ROON”.

I did launch a new display against another device on the network (a Chromecast connected to a TV) and it also stuck with the black screen only displaying “ROON”. It does that for a minute or two and then it looks like Core kills the display and it goes back to my normal Chromecast home screen. Tried on one of the Google Homes, same result. Another oddity: I don’t have two Google Hub: Kitchen devices, only one, so not sure why that’s showing up twice in Roon.

I’ll leave core up and running without restarting so let me know if there’s anything I can send your way from logs, etc.


Thanks, @rcrawley. That’s definitely a good data point — It sounds like the problem is on the Core side and not the display side (most likely, anyway). Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? I’ll take a look and see what’s happening.

1 Like