Web Display No Longer Updates (ROCK Core)

Since last monday I’m experiencing the same phenomenon: web display no longer updates, save when I refresh the browser. When I restart the core, webdisplay udates for say one song, but no longer.
When I restart a browser, it updates for 10 secs or so, then no more.

Core is on a Nuc i7
Behavior is reproduced on any windows10 machine, with Chrome, Firefox, Opera etc. All software updated to latest versions.

Hello @Johannes,

We’re going to do some testing here, but I’m not sure why this issue is affecting your setup more than the countless other customers we have, do you by any chance have anything strange set up on your network or machines? Possibly any firewall that could be blocking Roon’s connection? Please let me know.


Hi Noris,

Checked the rules and regulations of the firewall(s). Roon has all the rights it needs.
Running on my PC: W10, Kaspersky IS.
On the i7: Rock.
On the i5: W10, Bitdefender
I reproduced the issue on an iOS-machine with Firefox and Chrome, so it seems to me to be platform independent.

And though Firefox never really liked the displayfunction, on Chrome and Opera it functioned pretty well, untill recently. It doesn’t refresh unless forced to do so.

Thanks for the feedback here @Johannes – Noris has a ticket in with our QA team, and they’ll be looking into this once everyone is back after the holiday.

Sorry for the trouble here!

Hello @Johannes,

I have split your post from the previous thread to individually track this issue better. I have started a case for you with our QA team but just to make sure that they have enough information when they review, can I please ask for you to provide the following details:

  • Reproduce this issue once more and note the exact local time in your country (ex.8:26PM) when the web display is failing to update

  • A screenshot of your current Roon Settings -> Displays Page

  • Your Router model/manufacturer and the model/manufacturer for any switches, range extenders, powerline adapters, ect. used in your setup here

Please let me know this information when possible so that I can attach it to your case.


Hi Noris,

Yesterday the Roon interface was sluggish, so I rebooted the Core. It solved the sluggishness and for a little while even the display feature functioned as it should.
But alas, it was not to last. As to your requests:

  • Reproduced it today 3:35PM local time on Firefox, Chrome, Opera
  • Router: Netgear Nighthawk R7000
  • Switch Netgear GS108
  • Switch Sitecom LN121
  • No range extenders, adapters etc. All networking with regards to music is wired


Cheers, J.

Hello @Johannes,

Thank you for providing those timestamps. I have checked our diagnostics servers and it seems that the report from your machine has still not reached us yet, is your ROCK powered on and connected to the internet?

I spoke to QA regarding your case and one other thing that would help us diagnose the issue here would be the info from Google Chrome’s Developer Console. The way to access this info would be to:

  • Open a Google Chrome window on a Windows Machine and point it to Roon’s Web Display URL

  • Do not start playback or try to display to that Web URL yet (as in have just the Roon Logo Visible)

  • Press Control + Shift + I on a windows machine to bring up a similar side-bar:

  • Navigate to the “Console” section in both the top and bottom list, in the top it says (Elements, Console, Sources, Network, >>) and in the bottom it says (Console, Networking Conditions, What’s New)

  • Start playback to that Web Display and verify that the console updates with each track, there should be a set of actions that happen with each track change

  • After noticing the issue occur where the web display no longer updates, right-click on the console and press “Save As…” to save the output as a text file. Also note the exact local time in your country that it fails to display.

  • Verify that the text file actually contains content, you should have something like this saved to it:

display_ui.js:1147 subscribe_displays request
display_ui.js:220 new LRC with key a3003030312d313935373130 received for zone 1601c4d7a735820eb976a6233bee9ebd255c
display_ui.js:1187 update_settings request for display_key: 1237d603-b19e-4e23-8482-9d8fba961560
display_ui.js:291 display zone settings callback: {"enable_lyrics":true}
display_ui.js:220 new LRC with key null received for zone 1601ff772fb750d74ed42f50f6db692e242b
display_ui.js:220 new LRC with key null received for zone 16015bfba48a113bcd4639e66fcfea5b86e1
display_ui.js:220 new LRC with key a3003030312d343233363439 received for zone 16018ff9247f33b1169bd037fefaf6a89869
display_ui.js:220 new LRC with key a3003030312d31343438303939 received for zone 16019c8f7064a64bc74e26f9afd8d01a8f8d
display_ui.js:220 new LRC with key null received for zone 160116ef5f8c7927611fe379163f195cee8d
display_ui.js:615 clearing artist art
display_ui.js:1160 activate request for display_key: 1237d603-b19e-4e23-8482-9d8fba961560 zone_id: 1601c4d7a735820eb976a6233bee9ebd255c
display_ui.js:279 display zone callback: 1601c4d7a735820eb976a6233bee9ebd255c settings: {"enable_lyrics":true}
display_ui.js:51 using url:
display_ui.js:51 using url:
display_ui.js:615 clearing artist art
display_ui.js:51 using url:
display_ui.js:331 reportLrcView result: {"content_length":0,"headers":{},"verb":"COMPLETE","name":"Success","request_id":"3","log":true}
display_ui.js:83 fetch with status 200 for 8a98dec206109a60a043d94db31e6ebb
display_ui.js:105 created blob url blob: for 8a98dec206109a60a043d94db31e6ebb
  • Upload that file to our server for analysis (I will PM you instructions shortly for this step).

Please let me know if you are able to perform this step so that we can take a look under-the-hood and see if the reason for the issues is displayed in the console logs.


Will do; need a bit of time for that…

1 Like

Hi Noris,

I’ve been monitoring the system to see if the issue reproduced, but… so far so good with Chrome on any system. Whatever the glitch in the matrix was, for now it’s ironed out.

Tnx, J.

1 Like

Glad to hear that the issue has gone away @Johannes!
If it occurs again please let me know on this thread and provide the console logs so that we can take a closer look.


Well, it occured again. Noticed it sat 180105 at about 13:23 on a NUC running W10 and checked it 14:03 on a PC with W10.
I had the console still running on the PC, saved a textfile and uploaded JtoN 190105.log to your server.

Regards, J.

Thanks for letting me know @Johannes,

I can confirm that we received the file and have asked QA to take a look.


Hello @Johannes,

I wanted to touch base with some good news, which is that our technical team has been able to reproduce this behavior and we’ve opened up a bug report with our developers.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved. Thanks again for the report!

– Noris

Good to know & tnx for the update!

I just discovered yesterday that I’m experiencing this same issue with Roon 1.6.

I tried with two different versions of Safari and Chrome on MacOS, plus Firefox on my FireStick (just for fun). Setup works fine with all of the above, but screen never updates, except via a manual refresh.

Hi @noris,

Just to let you know that web displays updated without flaw, made it through the Roon 1.6 update, but as of today no longer update on Windows and OSX-based systems, rgeardless of browser used. No changes to rules and regulations on said platforms.

Hi @Johannes,

Apologies for the delay here. I have tired to reproduce the issue you reported but the web display features are working as expected on my end from both a Windows and ROCK core. Is this behavior still consistent after a full reboot of the ROCK? Can you please try these reboot instructions and let me know if it helps?

  • Open the ROCK Web UI
  • Press the power button in the top right-hand corner and select Reboot
  • Wait for the ROCK to reboot
  • After it is online again, try restarting just RoonServer Software

Please let me know if that helps.


Hi @noris,

My previous post was just hours before the release of build 401. Since upgrading to that version the web display feature performs nominal. If the issue raises its head again, I’ll follow the procedure outlined by you.

Thanks, J.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.