Weird audio dropouts with HQPlayer


I’m pretty new to HQ Player but I’ve read the forum for a little while. I’m having some problems with dropouts on my system and with the specs I have, I don’t think I should have some.

System is 12900KF with 3090 on windows running HQ Player Desktop. Roon is on another machine. My NAA is a Rasp pi4 connected to a Holo May KTE via USB.

I’m strictly using Tidal and Qobuz files with Roon and everything works fine for the most part except some dropouts once in a while. When they happens, my CPU drops out to 0% usage basically and then spikes. I’ve attached pics of my settings. Same thing happens if I unselect CUDA offload.

Any insight would be appreciated, it’s driving me crazy.

Have you you tried setting Multicore DSP to “Auto” (grayed out check box)?

Yep as @Steven_Edwards mentioned leave multicore on grey, not ticked

And also tick adaptive output rate

Everything else looks good

What don’t you run NAA OS on the RPi4 instead of RoPieeeXL? That wouldn’t be causing your issue, just a separate thing I noticed

Ok I will try that! Thanks @Steven_Edwards & @dabassgoesboomboom Running RoPieeeXL because that was what I was running before on the pi. What would I gain from switching to NAA OS?

Optimised for HQPlayer only. It is designed by Jussi to do just one thing - NAA function - and nothing else. Best performance and best reliability

RoPieee has always felt bloated in use to me.

DietPi is really good, lean.

But NAA OS is best.

Just burn to microSD card, same way as you did RoPieee.

Here’s the link. You need to unzip it using something like 7zip

Ok so I installed NAA and changed the settings and it’s still happening sadly… Same thing if adaptive output rate is completely ticked on.

Just a thought, does it happen with local files? I see you mention you only use streaming…

Do you have any local files of various bit rates you could use to test for dropouts during playback?

Ok so it wasn’t a PC problem… It was an ethernet cable problem. I’m able to do DSD512 no problems now.

Thanks for everything guys!