Weird DAC issue


I installed RoPieee (Pi4) a few days ago, it’s fantastic!

RoPieee works great with my IFI micro IDSD BL over USB.

I move to the USB DAC in my Yamaha NX-N500, it’s very odd, I get a continuous thumping sound, a couple of thumps every second, it visibly moves the woofers.

I tried another USB cable and Pi4, problem persists.

The NX-N500 USB DAC works fine on my Mac.

I only get the thumping after booting RoPieee, turning the Pi on without the SD gives silence. So I don’t think its electrical.

The driver for this DAC is maybe broken in Linux, I only found this:

“The NX-N500 speakers use the XMOS USB receiver chip. Using a Mac with newer versions of OS X or a USB Audio Class 2 compliant operating system such as several Linux distributions will not require driver/software installation”

I can see this on the Mac:

Product ID: 0x3138
Vendor ID: 0x0499 (Yamaha Corporation)

So I’m a bit stumped, are there things I can do over SSH?


The driver on RoPieee should be fine. It’s one of those “several Linux distributions”.

But you can rule out RoPieee by flashing an SD card with DietPi instead, and see if you get the same issue with that OS on the Pi.

Thanks, I tried plugging the NX-N500’s directly into my ROCK and get a similar issue so the speakers are broken under Linux.

1 Like

Just to get this clear in my head: so both ROCK (on a Nucleus?) and RoPieee (on a Pi 4), when connected via USB, exhibit the same issues?

Thanks, it’s ROCK on a Skull Canyon NUC. The issue was very similar, a repeating thumping noise, unusable, broken.

Nasty. What I’d try is getting one of the new Topping HS02 USB isolators, and seeing if that stops the noise. Return it, if not.

These NUCs apparently have low-quality USB hubs, so that might help.

Did you try the USB 2 ports?

Thanks, yes I did, I think this is a driver quirk, I don’t even think the DAC outputs music, when I heard the thumping start on the Pi boot, I quickly turned the speakers off to avoid damaging them, the thumping sound is loud enough to make me worry that it’s damaging something.

I’m now thinking that rooUPnP could be the workaround here.

I don’t think it’s a driver quirk. Lots of folks use those drivers (Pi and ROCK) quite successfully. It may be a problem with the USB software on the speakers. Interesting that the Mac appears to work fine with them over USB, right? Using iTunes to play?

Thanks, yes, a problem with the speakers USB software that would probably need a driver tweak to fix this quirk, similar to how UAPP on Android handles it (USB tweak 1,2,3 options in setting). No doubt the fault is with Yamaha’s XMOS USB implementation.

Yes, the Mac Mini (2018) work beautifully with them over USB, sounds fantastic, unfortunately there are no little, cheap, low-power headless Intel Mac’s available. Using Roon to play.

OK, gotcha now. No firmware upgrades for the speakers, I presume?

You could pick up a used Mac mini - perhaps 2014?

An ssd one would be quiet. And their power usage at idle is pretty low.