Weiss 501 DAC not found on Antipodes K40 Core

Since I upgraded the software, Roon can’t find my Antipodes K40, which means I can’t play any music through my system. It’s very frustrating.

Roon Core Machine

Antipodes K40

Networking Gear & Setup Details

Regular ethernet from the wall to the K40.

Connected Audio Devices

Weiss 501 DAC and Luxman integrated amp. XLR connections from DAC to Luxman. Ethernet cable connection to the K40 and from the K40 to the Weiss.

Number of Tracks in Library

Approximately 5,000 tracks

Description of Issue

It appears that after upgrading to 2.0, the Antipodes can’t be found by Roon. Yesterday, the connection was literally blinking on and off, which made it difficult to search. However, I could still play music. Today, the K40 can’t even be located. No idea what’s going on. Any ideas would be appreciated.

Here’s the action I’ve taken to try and get the connection back on.

  1. Switched out ports to plug ethernet cable into
  2. Rebooted the K40 multiple times
  3. Uninstalled and reinstalled Roon software. When I did that yesterday, it was able to find the connection. However, it can’t find the K40 today.


@William_Bly, I have moved your post to #support, so it is visible. Please complete the following template. Thanks.

Roon Core Machine

<!-- Include your operating system and machine info (Model, CPU, RAM) -‐>
<!-- Write below this line -‐>

Networking Gear & Setup Details

<!-- Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using VP -‐>
<!-- Write below this line -‐>

Connected Audio Devices

<!-- Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.) -‐>
<!-- Write below this line -‐>

Number of Tracks in Library

<!-- Tell us how large your music library is, eg. “30,000 tracks” -‐>
<!-- Write below this line -‐>

Description of Issue

<!-- Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated! -‐>
<!-- Write below this line -‐>

I posted this on Support, but didn’t get any response. Roon no longer recognizes my K40. I can’t play any music at this point, using Roon as the player. I don’t have squeezebox or anything. I downloaded the new update for the K40 and then it disappeared from Roon. Does anyone have any suggestions? I’ve tried unplugging and restarting the K40, trying different connections for the ethernet, reinstalling the software, etc, with no success. I’m at a total loss. Any help would be appreciated.

Some more information… It is clear that Roon can find all of my albums. I shut off Qobuz and Tidal as a test, and Roon has my albums showing up. But it doesn’t show the K40. I’ve tried having it search for the K40 without success.

I tried turning on Squeeze Player but I can’t play any albums through Squeeze as it says “No Player”. The albums are located, but again, I can’t play anything.

Any ideas?


What do you see in Roon settings: audio?
You should see the K40 as a Roon Ready endpoint but the name might be odd.
In the Antipodes web gui do you have the K40 selected as the Roon Player software from the choices of many?
I think on one update of Antipodes software it had changed my S30 from the Player from Roon AND changed the output from digital (USB) to analog.
Both items I would check in the Antipodes web gui portal first.

I am attaching the screen shot showing “Manage audio devices”.

This shows that the Antipodes isn’t found as an output device under audio. However, the antipodes USED TO SHOW up as the Roon core. However, I reinstalled the Roon Server, which now doesn’t even allow it the K40 to connect to Roon as a server. Whenever I click “connect”, it times out and can’t find it.

Roon is correctly selected as the server app on Antipodes GUI

Where is your Roon Core right now?
Trying to use the K40 or on another device?
If so can you check settings:about so we know what build it is on?
And you should be able to see what build the K40 is on to from the web GUI I believe.
Can you check Roon is also selected as player in the Antipodes Player section?

OK. I think I’ve figured out the issue. The antipodes is found as the core. The player, which is my Weiss, can’t be found. I’m going to track down that problem issue and go from there.


Hi @William_Bly ,

I’ve activated diagnostics for your account and noticed your Weiss DAC is now showing up properly. Have you been able to resolve the issues you mentioned with it showing up since your post? If so, can you please let us know what helped so others facing the same issue may benefit? Thanks!

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.