Western Digital MyCloudPR4100 Network Server, Software updated from OS3 to OS5, ROON can't find music files

Western Digital MyCloudPR4100 Network Server – With OS5 ROON Music Software can’t find music folder and files. My ROON Core is a Sonic Transporter i7 for ROON DSP. I use an iPhone X, iPad Pro, Dell PC and Dell laptop (Windows 10) all with ROON on them. As well as Trinnov Altitude 32 SSP presently out of commission as my theater is being renovated and upgraded.

I have both Western Digital MyCloudPR4100 32TB (DHCP reserved 192.168.1.214) and WDMyCloudEX4 16 TB (DHCP reserved 192.168.1.210) network servers. I use ROON Music software in my dedicated home theater. I have OS3 software for the EX4. I had OS3 software for the PR4100, just updated to OS5 for the PR4100.

My main music server is the PR4100. All my music is backed up also on the EX4.

My ROON music software had no issue seeing the DHCP address for the PR4100 with OS3. ROON still sees the DHCP address for the EX4 which is still OS3. But ROON no longer sees the DHCP address for the PR4100 which is OS5. Something changed from OS3 to OS5 such that ROON no longer sees the DHCP address for the PR4100.

Also the Western Digital Access program on my PC has no issues accessing the settings for the PR4100 or the files including music files.

I also have a Sony STR-ZA810ES receiver in my family room and I use Sony Music Center on my iPhone to access the PR4100 music files and with OS5 this still works fine. Though I found out that for this to work with the PR4100 I had to install the Twonky app.

I have been doing backups of my ROON core Sonic Transporter i7 software to both the PR4100 and also the EX4 regularly. When I go into ROON settings, it shows 192.168.1.210 for the EX4 and allows backup to the EX4; but now with OS5 on the PR4100 it shows that the address of 192.168.1.214 is not available.

Anyone have any idea how I can fix this?

You might verify that the WD MyCloud has SMB1 turned on. It seems that it is turned off in OS5 by default and you have to turn it on. Check this out and enable SMB1 if it is not already.

Hi Steve,

I had the same problem until I went into the NAS and changed Windows Services from smb 3 to smb 1, 2, and 3. You’ll see in my separate thread that this solved the problem.

Yes, this worked for me. Thanks.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.