WFMT Chicago, IL, USA issue

WFMT Chicago, IL, USA is one of the worlds premiere Classical Radio Stations (with some Folk Music on Saturday night). Roon currently lists 4 streams, but only the slow 128k mp3 actually connects. The high resolution stream is 256 HLS and is located at –

http://wowza.wfmt.com/live/smil:wfmt.smil/playlist.m3u8

This is the stream information I use in Audio Hijack to successfully make high bit rate recordings of specific programs on WFMT.
Can the three non-working streams be removed from ROON and this working high resolution stream be added to ROON for WFMT?
Thanks

Fred Geisler

Hello @Fred_Geisler and welcome to Live Radio.

I have just tried those 4 streams and all work for me.

As for the .m3u8 stream - Roon wouldn’t accept it as it was (it’s rather hit and miss with those at present), but I think I found a working sub-url from it. Please try.

Interestingly, when I type the default stream - ACC 256kbps of – http://stream.wfmt.com/main-source.m3u into safari (ver 15.1 on my Mac running macOS Big Sur 11.6.1) it stream fine. However, when I try to run in Roon the same stream, I get a “track failed to load” error message. I think I need to adjust a setting in ROON or the Mac OS to make this work. Any idea what need to be modified?
Fred Geisler

Just tried again - no problem - nor should there be, no adjustments needed.

Can you play .aac streams from other Radio stations?

(Can a moderator move this to its own thread please?)

I tried several AAC streams and none of them worked. However all the MP3 I tried worked from launch in the ROON program. Seems like something wrong in my setup somewhere.
Thanks for looking at this problem.
Fred Geisler

Ok. Seems to be a codecs issue, although you can play the .aac streams outside roon. If simple fixes don’t work (rebooting?) open a thread in #support and they’ll sort it.

(Edit. I’ve seen a suggestion elsewhere that downloading VLC helped - it presumably updated the codecs. No idea if that will work)