WGL function error

I have the same problem. I have an old Sony Vaio VGN-SZ3HP/B with dual core and 2GB of memory.
I hadn’t used it for a long time, but thought it might be fine as a Roon Core machine.
I upgraded it to Win 10 but now get the WGL error.

If this is just a core, then you should try installing RoonServer which does not have a GUI component. You would then connect and control it from a Roon installation on a different machine or tablet.

1 Like

hi @john_keeley,

Welcome to the forum! Just so you are aware, these are the minimum requirements for running a Roon Core, I would check to ensure your Core has this, otherwise you could run into performance issues as your Roon library grows:

Hi Daniel, that worked fine, but the Vaio was underpowered so I moved the core to my Asus K556U. I use TP-Link M5 mesh network extenders and get 50+ Mb which is perfect. As we both work from home, bandwidth can become a problem so I reinstalled the extenders in case they were degraded.
I now have a solid problem on all mobile devices, IPad, Samsung tablet and iPhone where I can see the Roon core on the app, but it continually says connecting, then connection failed repeatedly.
I can’t see what is different with the previous and new mesh networks or why the previous One worked and new one doesn’t.
Best regards
John

Hi @john_keeley ,

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.