What are the right ARC port forwarding settings for FritzBox 7583 VDSL?

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

  1. KPN/XS4all Netherlands

  2. FritzBox 7583 VDSL

  3. No routers, mesh network using Ubiquity switches and WIFI

  4. No

Connected Audio Devices

Chord Hugo 2 via USB + Sonos AMP1, Ifi audio Zen Stream + Ifi Hip-Dac

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?

Error message:
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect EHOSTUNREACH 86.94.xxx.xxx:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

Hi @Robert_van_Riel,

Did you have a look at this topic?


1 Like

Thanks Joost, I have. And I have actually succeeded in my Nucleus to show up and get a port forwarding entry in my router’s setting but I still get this error. Changing from IPv6 to IPv4 does’t help. I am probably overlooking something but I have no clue what exactly.

Some things to try…

  • Try to manually open the port in your router configuration
  • Make sure the IP/Port matches
  • Check for any VPNs or Firewalls
  • Reach out to your ISP

Thanks, Martin. The first two points you mention are confusing enough for me. I have set the port to what I see in my Roon ARC settings. But I am seeing different IP-adresses that do not match. IN the error message (see first post) I see an external IP mentioned that I do not recognize. The Nucleus’ IP is different from what I see as IP in the port forwarding settings on my router (see image). So I do not know what to change where, actually.

On second glance, the message indicates that you have a port conflict mapping error. Therefore, ensure no other apps are using the same port as Roon (or another Roon Core instance.)

The external IP starting 86.94 should be the IP assigned to you by your ISP.

Why do you have two entries for ARC? And what is the subnet for your network, and the IP of the Nucleus?

Hi @Robert_van_Riel,
You mentioned the Fritz!Box but also a mesh network with Ubiquity switches. So something like this:

Fritz!Box → Ubiquity → Nucleus ?

Do the Ubiquity switches also function as a router? If so, than you have to do port forwarding in both the Fritz!Box and the Ubiquity to find the Nucleus I think.

Hi Joost, your suggestion was helpful, as was the help from @Martin_Webster . I changed the ethernet cable that goes into my Nucleus from a wifi-hub to a regular switch and the problem appears to be solved. Thanks guys, I really appreciate the help and your swift replies.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.